German Umlaute replaced with a questionmark



  • Hello,

    I have the same problem as the previous speakers.
    ü ö and ä sometimes with one? shown.
    I tried everything that was suggested here

    kopano-localize-folder blabla utf8 etc.
    Customize / etc / locale
    nothing helps …

    the only thing that fixes the problem for a short time is a reboot
    of the apache webserver.
    after the prompt for new application appears, the
    Implementation of the umlauts correctly. if the user logs off two to three times
    the umlauts are no longer translated correctly.
    I have now suspected that my apache copies any files in its cache.
    That’s why I’ve tried caching off.
    GET /webapp/client/resources/images/loading_m.png HTTP/1.1
    Host: 192.168.2.17
    User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
    Accept: /
    Accept-Language: de,en-US;q=0.7,en;q=0.3
    Accept-Encoding: gzip, deflate
    Referer: http://192.168.2.17/webapp/client/resources/css/external/login.css
    Cookie: lang=de_DE.UTF-8; encryption-store-key=a8d7811fa6c6e77b3fb4c11e31b24212; KOPANO_WEBAPP=59mfrdc9d104s080nmp2usjvs4
    Connection: keep-alive

    HTTP/1.1 200 OK
    Date: Mon, 17 Sep 2018 18:32:06 GMT
    Server: Apache/2.4.25 (Debian)
    Last-Modified: Mon, 13 Aug 2018 14:35:25 GMT
    ETag: “c1953-1249-5735201026540”
    Accept-Ranges: bytes
    Content-Length: 4681
    Cache-Control: max-age=0, no-cache, no-store, must-revalidate
    Pragma: no-cache
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Keep-Alive: timeout=5, max=100
    Connection: Keep-Alive
    Content-Type: image/png

    but somehow that does not seem to help.
    I could reboot the apache every five minutes via a cron job.
    This solution is somehow silly.
    Sorry if my english is very scary …

    Thanks for any help…



  • I noticed another problem.
    If I put a calendar entry with umlauts this becomes
    also displayed without umlauts.
    A calendar entry consisting only of umlauts, for example üöä
    is displayed only briefly and then deleted.
    I have now made a trace with the help of Wireshark.
    Here you can see that the client sends the word “Gemüse” correctly to the server.
    The server but only “Gmse” answer.
    I also have screenshots but unfortunately I can not upload them here. #
    Here’s a text:
    Clientpc to Server:

    JavaScript Object Notation: application/json
    -Member Key: zarafa
    -Member Key: appointmentitemmodule
    -Member Key: appointmentitemmodule182
    -Member Key: save
    -Member Key: props
    -Member Key: subject
    -String value: Gemüse

    Response from server:

    JavaScript Object Notation: application/json
    -Member Key: zarafa
    -Member Key: hierarchynotifier
    -Member Key: appointmentlistnotifier
    -Member Key: appointmentlistnotifier1
    -Member Key: update
    -Member Key: item
    -Member Key: props
    -Member Key: subject
    -String value: Gemse

    Where can I start looking for the mistake?
    Can this be a problem with the database?



  • 0_1537273423594_28265c44-7c40-42ea-8890-4ca1ef922ab9-grafik.png

    ???



  • Problem solved :)
    An entry in the file / etc / apache2 / envvars helped:
    export LANG = “de_DE.UTF-8”


Log in to reply