Free/Busy: no information



  • Hi all,
    I have for testing purposes a fresh install of Kopano community edition version 8.6.80 and I manage my users with openldap on the same machine.
    Evereything is workin fine so far, but I don’t get free/busy-information when organizing a meeting. Every line - even my own - is grey (“no information”). Can anyone point me to how I can troubleshoot this issue?

    Best regards

    Thomas Blum



  • Maybe the public store was not created, the free/busy information is stored there.



  • Hi eli,
    thank you for your answer. You were right, the public store was not created. I now created it but still can’t get no free/busy information. I unhooked my user-store and created a new one but can’t see my own free busy information. Do you (or anyone else) habe further advice?



  • Hi to all,
    I just changed the value for free / busy publishing from the default 2 months to 3 months and now I can see my free busy information. After re-setting it to 2 months, free/busy information is still published. So, maybe this is a bug: leaving the value unchanged means not publishing any information, which is a good default behavior. But the field should then show a value of “0”.


  • Kopano

    Hi @q5616417, this may be because there was no free/busy information written yet. The free/busy information is written when you modify your calendar (e.g. add an entry) or change your free/busy publishing settings as you did.



  • Hi @bhuisman,
    thank you for your answer. I can confirm this. I created some appointments and meetings but not after creating the public store.

    Best regards

    Thomas



  • I have a problem like this,I can see my and others(have permissions) calendar(free/busy) in calendar menu.but I can not see them in meeting request -> scheduling page.freebusy.png .I tried your methods to change the FREEBUSY_LOAD_END_OFFSET to 90/60/30/15 in config.php,but no use.

    But it’s available in calendar:
    freebusy2.png

    Could you please give me some information,Thanks!@q5616417


  • Kopano

    Do you have a public store, @wkdljl ? If you don’t, you will need to create that first, then logout/login and create a (any) calendar item.



  • @bhuisman Thanks for your reply.
    I use kopano-cli --create-store to create a public store.I havn’t use multi-tenancy mode.And I use ldap.
    After created public store,I add two users jim and jeson throw phpldapadmin,but threre are another error:when I want to add permission in ADMIN account for new user jim,as follow pic:
    calendarpro.png
    I get an error,as follow pic:
    calendarerror.png

    I checked /var/log/kopano/server.log and /var/log/mail.log and /var/log/apache2/error.log,there are no more information.
    What should I do?
    I am very new for kopano,Thanks so much @bhuisman


  • Kopano

    @wkdljl sorry, I do not understand what you are trying to do. The user should already have permissions on their own stores, and as an admin you can open them without setting additional permissions.

    For free/busy, you do not need to set permissions (the data is stored in the public folder).



  • @bhuisman Thanks so much ,Now I solved this problem.I can see others’ free/busy.You are right,I havn’t created public store.
    But,When I add a new user,by default the new user have no privilege for his/her own calendar.Need administrator to give permission.I remove all users and recreate,my second problem be solved.
    Thanks a lot,You save me so much time!


Log in to reply