Language Loginscreen

Hello,

maybe there is a bug in the webapp.
The login screen is stil in English.

My system Debian 9 (Stretch)
Last Kopano community version
Webapp 3.4.21.1699 + 964-Debian_9.0-all

/etc/default/locale

LANG="de_DE.UTF-8"

locale:

LANG=de_DE.UTF-8
LANGUAGE=
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

/etc/apache2/envvars

. /etc/default/locale
export LANG

PHP test:

var_dump($_SERVER);

 ["LANG"]=>
  string(11) "de_DE.UTF-8"

/etc/default/kopano:

KOPANO_LOCALE="de_DE.utf8"                                                                                                        
KOPANO_USERSCRIPT_LOCALE="de_DE.utf8" 

I testet set manualy in webapp config.php

$_ENV["LANG"] = "de_DE";          

Is there a posibility to check if $_ENV[“LANG”] corectly set?

Greets
Thomas

As with any website, I expect it to honor the language preference list as sent by the browser (“Accept-Language:”), not any system setting.

Hi,

yes, but german is the first language set in browser preference.

hi tommi,
I thought to have the same issue. After Upgrading to 3.4.20.1690+74.1 my welcome screen suddenly was english.
But after restarting Kopano-server - now its german again.
Have you tried a simple restart?

Hi,

yes I restarted Kopano and apache.

Hi marty,

yes I know but I like to figure out why webapp behave like this. maybe i have overseen something or there is really a bug.
It is not so annoying because after login the language is correct.