German "Umlaute" not showing correctly in Webapp

Hi again ;=),

I see a “?” for a “ü” “ä” but just in the Webapp Frontend so the text in the mail is correctly displayed. Why they are not showed correctly in the frontend?

0_1533047660469_frontend_umlaute.png

Thanks for any help :).

I have downloaded kopano tools and try to use that but I get an error. I have downloaded the script package and unzipped it to: :/home/kopano/core_tools_kopano/localize-folders

No I go into that folder and run: python localize-folders.py --user USERNAME --lang de_DE.u

I recieve:

Localizing user: username
Changing localized folder names to "de_DE.utf8"
'ascii' codec can't decode byte 0xc3 in position 3: ordinal not in range(128)

Script:
https://stash.kopano.io/projects/KSC/repos/core-tools/browse/localize-folders/localize-folders.py

I found this thread:
https://forum.kopano.io/topic/810/special-characters-are-shown-as-question-marks/4

Hi @hispeed,
Is your issue about wrong Umlaut-decodings in:
a) folder-names
b) mail-items/subject-lines?
For the latter, you might continue in “Incorrect umlaut and special character decoding in mailbody” or “German Umlauts broken in the subject line of sent mails”.

++umgfoin

Hi umgfoin,

Very interesting posts.

I have a similar problem and it looks like a problem which pops up every few months…

Were do I see the “?”:

In the Webapp preview lines of the e-mail as well as in the Subject of the mail. I also see in the name (contacts). It’s the same via Z-Push on my Iphone 7 latest IOS.

The folders: “Gelöschte Objekte” or the others are ok. Also OK are folder which I have created on my own.

What collacation to you have at your sql table?

EDIT:
https://jira.kopano.io/browse/KC-1139
It probably is this issue. I will wait and confirm if Kopano V.8.7.0 will fix it.

@fbartels

I’m not sure if this is the same as KC-1139. Can you take a look into that?

I run the localize script for every user something has changed. I see now “Gelöschte Objekte” correct. But when I now create a folder with “ü” it’s showing with ?. Before the script i saw “Gel?schte Objekte” but it was possible for me to create a new folder with “ü” and it showed correctly.

As you know I have Ubuntu 10. As I mentioned above when I run the localize script I recieve an error.
Do you already know when KC-1139 will be fixed?