Webapp 3.4.17.1607-71.1 Centos 7

Hello guys,

i got an error on latest pre-final on CentOS7. Probably easy to fix but i haven’t looked into it yet.

==> /var/log/httpd/error_log <==
[Wed Jul 04 15:35:25.667633 2018] [:error] [pid 355] [client 192.168.122.13:48318] PHP Parse error:  syntax error, unexpected '=', expecting ')' in /usr/share/kopano-webapp/server/includes/core/class.theming.php on line 40

==> /var/log/httpd/access_log <==
192.168.122.13 - - [04/Jul/2018:15:35:25 +0000] "GET /webapp/ HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36"

[root@kopano webapp]# rpm -q kopano-webapp
kopano-webapp-3.4.17.1607-71.1.noarch

Greetings
Markus

Hi @mkoas

I got an error even i go to the webapp. Error 500

Do you get the same?

Hi @ckruijntjens ,

the error 500 was the reason for looking into the logfiles ;)
I got it working after editing this line but i don’t know if i got it as the wanted it to work.

Hi,

I’ll have a look at this issue.

@mkoas

What was iT that you changed?

@mkoas @ckruijntjens
Thanks for the reports.

I’ve created https://jira.kopano.io/browse/KW-2679
Please track it for status updates.

@mkoas @ckruijntjens Could you retry the pre-final packages?

@ckruijntjens sry i didn’t see your question yesterday and just came back from todays work ;)

@marty it works for me
Seems like i’m getting error messages because i don’t use public stores but i don’t know if they were present before and they are logged as PHP warnings, so i don’t really care