PHP-MAPI extension is not available

Hi,

We are running Z-Push 2.4 and Kopano 8.5 on a CentOS 7 server.

When I try to run a z-push-admin (for instance z-push-admin -a lastsync) I get an error saying:
FatalMisconfigurationException: PHP-MAPI extension is not available

php-mapi-8.5 is installed.
Can somebody tell what I’m missing here

Kind regards,
Cor van den Berghe.

it seems php-cli is using a different php version than the webserver is using (assuming of course there you don’t get an error because of missing php-mapi)

We are using the PHP 5.6 software collection, can you tell me how I can tell the webserver which php version to use

Regards,
Cor.

Never mind, I fixed it. I ran this command (again) to enable PHP 5.6
scl enable rh-php56-php

Thanks for your help.

Kind regards,
Cor.

Hello @acha,

this command enables php56 for the session till next reboot.

i recommend to use

source /opt/rh/rh-php56/enable

this should create a system default to this version.

coffee_is_life

@coffee_is_life

A bit late, but thanks for your suggestion.

Cor.