Kopano Server connects with Zarafa client, but not Kopano OL extension.



  • Hello

    I have a kopano test server running.
    I wanna test if i can connect with zarafa client AND kopano OL.

    Zarafa works fine i can connect to the server with outlook.
    Kopano OL extension doesnt work though.

    Outlook fails to connect saying something like:
    "Cannot login to Exchange ActiveSync-E-Mail-Server (EAS): The server wasnt found " (I translated this to Englisch, original message might differ slightly.)

    I can ping the server and it does answer.
    Also it works perfectly fine using Zarafa.

    If anything, i expected it the other way around, with Kopano working and Zarafa not working.
    Kopano should be stable i guess?

    ///////////////////////////////////////////////////////////////////////////////////////////////////
    Specs bellow:

    Server:
    Centos7
    kopano-server 8.6.2

    Client:
    Win7 - 32bit
    Outlook 2016
    Zarafa-client 7.2.6
    KopanoOL extension 1.6

    Kopano doenst help with any usefull error log files.
    I tried to enable as much logging as possible in /etc/kopano/server.cfg file.

    ##############################################################
    # LOG SETTINGS
    
    # Logging method (syslog, file), syslog facility is 'mail'
    #log_method = file
    log_method = file
    
    # Logfile (for log_method = file, '-' for stderr)
    #log_file = -
    log_file = /var/log/kopano/error.log
    
    # Loglevel (0(none), 1(crit), 2(err), 3(warn), 4(notice), 5(info), 6(debug))
    #log_level = 3
    log_level = 6
    
    # Log timestamp - prefix each log line with timestamp in 'file' logging mode
    #log_timestamp = yes
    
    # Buffer logging in what sized blocks. 0 for line-buffered (syslog-style).
    #log_buffer_size = 0
    

    and

    ##############################################################
    # AUDIT LOG SETTINGS
    
    # Audit logging is by default not enabled
    #audit_log_enabled = no
    audit_log_enabled = yes
    
    # Audit logging method (syslog, file), syslog facility is 'authpriv'
    #audit_log_method = syslog
    audit_log_method = file
    
    # Audit logfile (for log_method = file, '-' for stderr)
    audit_log_file = /var/log/kopano/audit.log
    
    # Audit loglevel (0=no logging, 1=full logging)
    audit_log_level = 1
    
    # Audit log timestamp - prefix each log line with timestamp in 'file' logging mode
    audit_log_timestamp = 1
    
    ##############################################################
    

    Any ideas how i can search for the cause of that issue?

    Cheers
    -Pfl


  • Kopano

    Hi @pfl ,

    is there anything logged in you webserver logs when outlook tries to connect? Have you setup an ssl certificate for the z-push vhost? have you done any ssl hardening on that vhost?



  • Hi @fbartels,
    Thx, for replying.

    Let me explain further.

    • No hardening happened.
    • No z-push installed.
    • Thus no ssl for z-push.

    The server is only running in a local network.
    And we only need to confirm that we can connect to Kopano-Server using outlook2016 with kopanoOL client.

    I think for this we dont need z-push at all?
    Or is that a dependency for Kopano to run properly?


  • Kopano

    @pfl said in Kopano Server connects with Zarafa client, but not Kopano OL extension.:

    I think for this we dont need z-push at all?
    Or is that a dependency for Kopano to run properly?

    It is at least a dependency for Outlook 2013 and above (as they now connect through activesync, which is provided by z-push)



  • Hey @fbartels ,
    Sry my head was somwhere else…
    z-push is installed xD

    But i didn’t confugre ssl yet.
    I’m gonna do that and see if it helps.



  • It works now.
    Seems like ssl is mandatory for it to work.

    Thx @fbartels : )
    -pfl