contacts in GAB and autocomplete email address wrong sorting order (surname name)

Hey all,

when using Outlook 2013 with Kopano Server and Outlook Extension all contacts in GAB are sorted as “Surname Name”. That’s bad because it should be “Name Surname” just as it was before when we were using Zarafa client. Even when I click on “New Email” --> “To:” button and the GAB pops up the names are sorted with surname first. When I choose a name, the TO:\ field shows it also listed as “Alice Miller” and Outlook autocomplete feauture saves it exactly under this sorting order. That means that when some days later I want to send an email to Ms. Miller and I start typing “mil” her name is not showing up. When I start typing “ali” her name shows up by the autocomplete feauture in Outlook and so I got her name “Alice Miller”.

I played around and did following:

OUTLOOK --> File–> Accounts Settings --> Accounts --> Adress Book --> Outlook Adress Book (MAPI)

There I have two entries called “Adress Book for mydom.ain: Kopano Folder” and "Contacts: mykopanologinname"
For those both entries I set the configuration in this window for “Name sorting” to radio button “Same as <saved as…>” Then I click OK button and restart Outlook. Now in the main Email view within Outlook I click on the button ADRESSBOOK on the top right area of Outlook2013. I see the names sorted by “Name Surname”. Looks fine so far, but:

whenever I write a new email, at the time I choose the contact from the GAB (which is showing the desired sorting order name/surname) it is shown up with sorting order surname/name next to the TO:\ field. This results again that Outlook saves this name in the autocomplete list with wrong sorting order surname/name.

So please, can anyone shed some light into this issue? I just want to have all the names sorted by Name/Surname so Outlook 2013 also remembers them with this sorting order. How can I fix this?

any help appreciated, thank you in advance.

is that really me only facing this?
noone?

If you look in the Microsoft Outlook forum, you will see a lot people with that question. The autocomplete function (since 2013) just uses the display name as the search order and there is no way to change it.

We turned off the autocomplete function, so that the users have to use the “check name” button.

Hi Eli,

I am using Outlook2013 since years on my own Windows 7 workstation. The software package “Zarafa Outlook Client 7.2.6.52189” is still installed on my workstation. I have configured two “MAIL” profiles on Windows7. The first one is called “using Kopano ActiveSync” and the second is called “using Zarafa-Client”. When I start Outlook I get a popup and asked which profile I want to use. So when I start with “Kopano” profile the mail account is configured to use “Outlook.com or Exchange Server” so it’s connected to our Kopano Server. When I launch Outlook with “Zarafa” profile the mail account is configured to use “Zarafa Client” which will connect to our Kopano Server. By this way I can do experiments and debugging.

As a result and as you certainly see the reason for that culprit cannot be Outlook2013. Because when I use Outlook2013 with ZarafaClient it works fine. The issue exist only when not using Zarafa Client any more, but instead connect through ActiveSync to Kopano Server.

The difference is even visible on the global adress book.

When using ZarafaClient the global adress book looks like that:
Image

When using Kopano ActiveSync with KOL the global adress book looks like that:
Image

As we can see, when using Kopano Outlook Extension the view is completely different. Also there are missing the columns like Department, Phone, Fax, etc. In this view you get the column “Displayname” (in german it’s called “Anzeigename”) which is surname-name order. That is wrong and unexpected. I checked the ActiveDirectory data. The “DisplayName” column in our ActiveDirectory is correctly shown as “Miller, Bob” (Name, Surname) and not “Bob Miller” (Surname Name).

This issue mentioned here is one of many others we are facing at that moment when trying out our new Kopano Server in conjunction with Outlook2010/2013. That is the reason why only we (=administrators) are using Kopano ActiveSync +KOL connection for testing purposes. All other employees still are using Zarafa Client until we get an overview what’s missing or different.

So if this issue is somehow solveable, please let us know. Thank you in advance.

is there anything I missed and can I somehow get the old functionality as we had with Zarafa client? How can I fix that?

pushed
anyone ?