S/MIME upload certificate failed



  • @marty
    Hi marty,

    as I can see there´s a solution now but when will the 3.4.16 Version become stable? It would be important because of the GDPR.

    regards Ari


  • Kopano

    We are working towards a release. If you can’t wait for the fix you should give the master build a try on a test server and if it’s stable enough you can use that.



  • Ok, thank you for your suggestion. I will try that.



  • Hi marty,

    thank you, the upload works perfect! But now I have the problem that I can not open the attachements from the encrypted mail. The log-file says the following message:

    [Wed Jun 13 13:29:17.457819 2018] [:error] [pid 15755] [client 10.0.178.210:48628] PHP Fatal error:  Uncaught Error: Call to a member function getRecipientProperties() on null in /usr/share/kopano-webapp/plugins/smime/php/plugin.smime.php:1137\nStack trace:\n#0 /usr/share/kopano-webapp/plugins/smime/php/plugin.smime.php(302): Pluginsmime->removeDuplicateRecipients(Resource id #13)\n#1 /usr/share/kopano-webapp/plugins/smime/php/plugin.smime.php(82): Pluginsmime->onEncrypted(Array)\n#2 /usr/share/kopano-webapp/server/includes/core/class.pluginmanager.php(550): Pluginsmime->execute('server.util.par...', Array)\n#3 /usr/share/kopano-webapp/server/includes/util.php(497): PluginManager->triggerHook('server.util.par...', Array)\n#4 /usr/share/kopano-webapp/server/includes/download_attachment.php(187): parse_smime(Resource id #6, Resource id #13)\n#5 /usr/share/kopano-webapp/server/includes/download_attachment.php(844): DownloadAttachment->init(Array)\n#6 /usr/share/kopano-webapp/server/includes/load.php(44): include('/usr/share/kopa...')\n#7 /usr/share/kopano-webapp/index.php(217): include('/usr/share/kopa...')\n#8 {main}\n   in /usr/share/kopano-webapp/plugins/smime/php/plugin.smime.php on line 1137, referer: https://10.1.178.101/webapp
    

  • Kopano

    Which version of the s/mime plugin is this?



  • @marty

    kopano-webapp-plugin-smime 2.1.1.77-9.1


  • Kopano

    That’s an old version, latest final is 2.2.0.



  • @marty
    Thank you, marty! That was the solution. It was an old version.

    greetings
    Ari



  • @marty

    i am trying to upload a certificate but its nor working. Error 500. however in the community edition i only see version 1.0? is this an error?


  • Kopano

    @ckruijntjens Can you post the error?

    The tarbal has version 1.0, the s/mime plugin version inside has the correct version, so I wouldn’t worry about that.


Log in to reply