Error messages when creating calendar entries in Outlook 2016



  • Hi,

    when I am adding a new calendar via Outlook 2016 and then try to edit the timeframe via drag and drop or edit the colour coding I am getting two error messages. The first one is that the element cannot be changed because it was used/changed by another or opened in another window.
    The only option I am offered then is to copy the element and put it into the standard folder. The second error is that a reminder cannot be shown for the element because it is in a folder that does not support it.

    The odd thing is though, that if I create an element, click on save and close, then reopen it and close it again those errors do not happen.

    Is there any chance to get rid of this behavour?

    Thank you very much in advance
    cheers
    -gladston31_1490634579305_error2.PNG 0_1490634579304_error.PNG


  • Kopano

    Did you create this calendar via Outlook? Is it visible in the Webapp for the same user?
    Normally OL via ActiveSync doesn’t allow you to create folders other than email folders.

    I think the issue is not that you are creating these items, but how you created the folder.
    Could you try to create the folder via WebApp and then to redo these actions in the new calendar via Outlook?

    Cheers,
    Sebastian



  • Hey,

    I did not create a calendar at all. I just created the account by logging in via the webapp and then connected my outlook to it. Then I switched to calendar and created an entry in outlook in the default calendar which was already there.

    The event was successfully synced to the webapp but I do get the errors from above until I either open the event once again or close outlook completely and open it again.

    0_1490644449747_error3.PNG

    0_1490644455602_error4.PNG


  • Kopano

    It took some time to get this case reproduced, but we know what is happening.

    OL has a feature that prevents that data is accidentally overwritten. You can reproduce the same error following these steps:

    1. create a calendar item
    2. make sure it’s synchronized and visible in Webapp & OL
    3. open the calendar item in Outlook, edit something but do not save (just keep the window open)
    4. open, edit & save the same item in Webapp
    5. wait a couple of seconds so OL has time to sync these changes
    6. try to save the already open OL item (of step 3)

    Result: the exact same failure message

    In this case it makes perfect sense, because you did change something in Webapp and if you would be allowed to save in step 6 you would lose this data without even knowing.

    What happens in your case is, that the first sync of the newly created item is not finished when you open the window for editing. A few (mili)seconds later, the sync process updates the item saving the newly created item ID from the server in your Outlook store. The item is then marked “as modified” and you can not save anymore, just create a copy.

    It’s an “Outlook feature” and I think there is not much we can do here.
    We could investigate if we can detect such case via KOE and prevent you from opening the item before the answer from the server is processed. Ideally it would “just delay the open action” for a second or two, or give you a message to wait and retry.
    Not sure if this is possible for dragging, but possibly not.

    Could you try to reproduce, but waiting let’s say 5 seconds before you try to drag the item?

    Is your store fully synched or is the OL taskbar showing “Downloading data from server” / “Updating folder xxxx”?
    If the sync is not fully finished that could also explain this, as the response from the server takes longer.

    Cheers,
    Sebastian



  • Hi Sebastian,

    thanks alot for your investigations and your time you put into this.

    I did not do anything in the webapp though besides checking if the entry was successfully synced. I think the best way to get an idea of my error is to see it with your own eyes. So I made a short screen capture video. It’s just a little bit over 2 minutes long so it shouldn’t be too time consuming.

    The time between the creation of an element and the “drag changing” doesn’t seem to matter at all. Also outlook should be fully synced.
    The only thing which seems to always get rid of the error is the reopening and resaving of the element a second time.

    But I showed all that in the video:

    https://cloud.ristl.it/index.php/s/psUyuZS3sqOUjla

    If you need any more information or a second video (:wink:) just let me know. I am happy to provide any additional information.

    cheers
    -gladston3



  • Ok, I investigated this further myself and it seems to be a local outlook problem. I tried two other PCs real quick and there it worked. What I did not try is to install the Kopano OL plugin since those PCs were production ones.
    What is strange is that the same error occurs now with a native exchange connection too. And that was definately not happening before. So I will try to find out the cause and let you know if I can find something and if it is related to kopano or its outlook plugin.


  • Kopano

    Hum, indeed what I see in your video is only partly explained by what I tested.
    The way via the webapp is just to confirm the theory, it’s not required.

    I also learned from the video that you don’t move the appointment to a new time/data, but just change the duration (which is a different test case).

    Your hint about KOE got me thinking. I could reproduce the issue by changing the duration and the error vanished after I disabled KOE. This might explain why this also happened with Exchange for you afterwards.

    I created a ticket for the KOE to investigate this: https://jira.kopano.io/browse/KOE-92

    Cheers,
    Sebastian



  • Hey @Sebastian ,

    I played around some more today. I completely removed the Kopano Outlook Plugin and now the " element cannot be changed because it was used/changed by another or opened in another window" error is gone.
    What stayed though, is the second “reminder” error. It still can be fixed with the reopening and resaving procedure.
    I already did a complete repair of my office suite but that did not bring any improvements. If I find some time I am going to set up a VM with Office and see if I can reproduce the error or if it’s just random local thing.
    I will keep you updated of course. If you have any hints or tips, just let me now (:

    cheers
    -gladston3


  • Kopano

    H @gladston3 ,

    we now have a build in QA that should fix this error. Do you want to give it a try as well?

    This change though comes with the risk of reintroducing crashes in low memory system (the pre 1.2.127 behaviour), therefore we decided to make it configurable for now.



  • Hey @fbartels,

    I am for sure interested in trying this out. What do I have to do? Update KOE or Z-push or both to the latest version? And where do I find the configuration switch?

    Thanks in advance
    cheers
    -gladston3


  • Kopano

    @gladston3 I’ve just uploaded the new build to https://download.kopano.io/supported/olextension:/pre-final/

    EDIT: there is a new option in the global section of the PluginDebugger.exe called “ReleaseItemEventWrappers”, that controls this behavior. It defaults to true, if it causes problems it could be switched to false to have the old behavior back.



  • Funny. I have the exact same problem without ever using the KOE plugin, just pure Activesync on Outlook 2016! It drove me crazy - then when I investigated it I found that it only happens when the “Teamviewer Meeting Add-In” was enabled in Outlook 2016. This gets installed by Teamviewer automatically (even though I’ve never used the Teamviewer Meeting functionality).

    Since I’ve disabled the Teamviewer Meeting Add-In this weird error message is gone!



  • @Gerald

    Interesting - I’ve also this messages and teamviewer installed too - so i deactivated teamviewer plugin as I never used it too
    Will see if this is now gone - will give feedback here in the next days

    rg

    Christian


  • Kopano

    I had this issue also without the Teamviewer extension (just checked, it’s installed but deactivated).
    Latest KOE 1.3 has fixes for this behaviour and the calendaring is working fine now.

    There is still a similar issue that happens when flagging emails after moving them.
    https://jira.kopano.io/browse/KOE-103
    We haven’t found a solution for this yet.

    Cheers,
    Sebastian


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.