files-plugin "Internal Server Error"

I have three virtual machines running on an EXSi.
1st AD master
2nd AD backup with Kopano and WebAPP
3rd AD backup with SMB shares

On the 2nd server I installed php-curl and CIFS. The SMB shares on the 3rd server are accessible on the 2nd server via mount - cifs “//sub.domain.tld/share” -o username=user,password=pass,domain,DOMAIN,vers=2.0 /mnt/share.

When I try to include a share in the WebAPP I get an error: “HTTP 500”-“Internal Server Error”. This also happens when I want to include file shares from an external NAS.

Which logfile may contain more information?

Translated with www.DeepL.com/Translator

Hi @bitboy0 ,

for further investigation some more information are needed:

  • which os are you running?
  • which version of Kopano, WebApp and its plugins?
  • which versions have the package dependencies (e.g. php-curl)?
  • what is logged in the webservers error logging when the error 500 occurs?

ok … found something…

[Thu May 17 13:21:46.054453 2018] [:error] [pid 28835] [client 10.10.10.99:49807] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 67108872 bytes) in /usr/share/kopano-webapp/plugins/filesbackendSMB/php/lib/SMB/src/Connection.php on line 43, referer: https://mannheim.wedia.de/webapp/

II downloaded the finished UCS virtual machine for EXSi and then installed Kopano Core, Webapp etc. via the AppCenter. So the latest version of everything.
The Kopano server has 16GB RAM. According to TOP 2.7GB are free and 12GB are used for cache.

I use the base subscription für UCS and Kopano for 30 Users

This post is deleted!

root@mannheim:~# apt-cache show php-curl | grep Depends
Depends: php-common, php7.0-curl

Die neuesten Pakete sind jeweils installiert.
Latest packages are installed

The one version I have asked for you did not post.

https://help.univention.com/t/http-500-internal-server-error/8656/15 suggests that installing one package out of the unmaintained repos of Univention could make the error go away. I’ve already added it to the upload of the next WebApp update on Univention but did not have time to further look into this myself.

So the UCS-Version is 4.3-0 errata83
Kopano is at 8.4.5.0
File-Plugin is 2.0
SMB/CIFS Backend 0.1

A week ago I had built a test installation in only one VM. But the same components. At first I had the problem that the php-curl was missing. But when I reinstalled it, it worked. There was no flaw.

I then used the findings from the test to build the production environment and think I did nothing different. But now I have this error.

No, I was more talking about the actual version of php-smbclient. The thread on the Univention forum suggests that pulling this in from the unmaintained repository makes the “memory exhausted” errors go away.

Thank you! That helped!
unmaintained activated, then apt-get install php-smbclient and /etc/init.d/apache2 restart.

Now that works fine again!