kopano webapp plugin-spell-nl broken

Hi when i install this plugin webapp is not available anymore afte login error 500. If i install the english spell checker it works as it should!

Name : kopano-webapp-plugin-spell-nl
Arch : noarch
Version : 2.0.0.0
Release : 4.6
Size : 593 k
Repo : kopano
Summary : TinyMCE Spellchecker plugin for Kopano WebApp
URL : http://www.kopano.com
License : AGPL-3.0
Description : The TinyMCE Spellchecker plugin, which adds spellchecking
: functionality to the TinyMCE editor, Dutch dictionary.

Hi @ckruijntjens ,

Not really on topic, but already back from Zimbra?

Back to topic: what always helps to investigate an error 500 is what is logged in the webservers error logfile. From in other topics you have mentioned that you are on centos 7 (still the case?), Which version of master?

@fbartels

yup already back now that the core is workign again. i am still on centos 7

core-8.6.80.590_0%2B59-RHEL_7-x86_64.tar.gz

i am running all the new packages from the nightly build.

this is the error in the httpd log:

[Mon Apr 16 21:11:46.771778 2018] [:error] [pid 1124] [client 192.168.2.162:60471] PHP Fatal error:  Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /usr/share/kopano-webapp/server/includes/core/class.pluginmanager.php:849\nStack trace:\n#0 /usr/share/kopano-webapp/server/includes/core/class.pluginmanager.php(849): SimpleXMLElement->__construct('<?xml version="...')\n#1 /usr/share/kopano-webapp/server/includes/core/class.pluginmanager.php(417): PluginManager->extractPluginDataFromXML('<?xml version="...', 'spellchecker-la...')\n#2 /usr/share/kopano-webapp/server/includes/core/class.pluginmanager.php(211): PluginManager->processPlugin('spellchecker-la...')\n#3 /usr/share/kopano-webapp/server/includes/core/class.pluginmanager.php(164): PluginManager->readPluginFolder(Array)\n#4 /usr/share/kopano-webapp/index.php(174): PluginManager->detectPlugins('')\n#5 {main}\n  thrown in /usr/share/kopano-webapp/server/includes/core/class.pluginmanager.php on line 849

@fbartels

Any idea yet? Is it someting i can do to fix it?

@ckruijntjens I checked this on a Centos7 machine, but works fine for me…

That plugin is not updated for some time, so is it the first time you installed it?
Could you post the exact package version?
rpm -qa | grep kopano-webapp-plugin-spell-nl

@marty

Hi marty. Yes I freshly installed the server on a centos 7 machine. The inglish package is working fine however if I install the nl package I get error 500 in webapp site.

kopano-webapp-plugin-spell-nl-2.0.0.0-4.6.noarch

hi @marty

Just saw a error in my log file.

[Wed Apr 18 20:24:28.141272 2018] [:error] [pid 1737] [client 192.168.2.6:50338] Unknown language: ‘nl_NL’

What did i forget to install? Thanks in advance for you help in this.

You need to install the nl_NL locale.
It will probably solve the issue.

@marty

Hi marty it is installed and was installed?

@marty

Infact all the locales have bin installed. When i do a locale -a

I see nl_NL in the list.

@marty

yust upgraded to the latest nightly builds and now it is working again!

@ckruijntjens Great. Not sure why, but great :)

Hi @marty

Gust upgrades to webapp version 3.4.17.1607. In centos 7 now i got the same issue as 2 months ago.

Error 500?

We did not make a change in the spellchecker,
not even the first time when you opened the topic.

Are you sure the error 500 is not this one? https://forum.kopano.io/topic/1561/webapp-3-4-17-1607-71-1-centos-7/2