Outlook stops syncing

Hello

The Outlook Profile of a Kopano User today “suddenly” stops syncing.
The state of syncronisation stays “disconnected”.

The user creates a new Outlook Profile and it starts syncronisation.
After some minutes the Message of " detected contact folders" appeared and Outlook is restarted.
Now the syncronisation not continued and stays disconnected.

In z-push log i found following errors

27/03/2018 10:27:25 [12219] [ERROR] [stein] ZPushAdmin::AdditionalFolderList(): state for device '2f34ad17b4d04adb9b41506d73411a82' of user 'stein' can not be found
27/03/2018 10:27:25 [12219] [WARN] [stein] /usr/share/z-push/lib/webservice/webservicedevice.php:173 Invalid argument supplied for foreach() (2)
27/03/2018 10:27:25 [18051] [ERROR] [stein] LoopDetection->ProcessLoopDetectionPreviousConnectionFailed(): Command 'FolderSync' at 27/03/2018 10:27:25 with pid '12219' terminated unexpectedly or is still running.
27/03/2018 10:27:25 [18051] [ERROR] [stein] Please check your logs for this PID and errors like PHP-Fatals or Apache segmentation faults and report your results to the Z-Push dev team.
27/03/2018 10:27:26 [18051] [ERROR] [stein] LoopDetection->ProcessLoopDetectionPreviousConnectionFailed(): Command 'FolderSync' at 27/03/2018 10:27:25 with pid '12219' terminated unexpectedly or is still running.
27/03/2018 10:27:26 [18051] [ERROR] [stein] Please check your logs for this PID and errors like PHP-Fatals or Apache segmentation faults and report your results to the Z-Push dev team.

In which logs should i search .
Any Idea of the problem or a solution

Thanks Bskoeln

hello @bskoeln,

KOE will create a logfile in %appdata%/temp/
there should be more info when it stops and why

coffee_is_life

CentOS 7.4.1708
Mariadb-5.5.56-2
KC 8.5.4.0-9.1
WebApp 3.4.5.1202-47.1 external Server - TCP-Socket
Z-Push 2.3.9+0-90.1
PHP-MAPI 8.5.4.0-9.1
PHP 5.6.25 with Zend OPcache v7.0.6-dev
DeskApp 1.5.0
Outlook 2016(64bit) KOE 1.6.282
Outlook 2010 -Zarafa 7.2.6

I am not a log file expert… but in KOE log i found no errors.
In the apache error log at the time of outlook restart in the new profile I found :

[Tue Mar 27 11:05:42.954099 2018] [:error] [pid 19260] [client 192.168.123.26:55125] exception 'MAPIException' with message 'MAPI error ' in /usr/share/kopano-webapp/server/includes/core/class.mapisession.php:530\nStack trace:\n#0 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(530): mapi_openmsgstore(Resource id #5, '')\n#1 /usr/share/kopano-webapp/server/includes/core/class.operations.php(703): MAPISession->openMessageStore(NULL)\n#2 /usr/share/kopano-webapp/server/includes/core/class.operations.php(288): Operations->getFavoritesFolders(Resource id #77, Array)\n#3 /usr/share/kopano-webapp/server/includes/modules/class.hierarchymodule.php(387): Operations->getHierarchyList(Array)\n#4 /usr/share/kopano-webapp/server/includes/modules/class.hierarchymodule.php(85): HierarchyModule->hierarchyList()\n#5 /usr/share/kopano-webapp/server/includes/core/class.jsonrequest.php(57): HierarchyModule->execute()\n#6 /usr/share/kopano-webapp/kopano.php(137): JSONRequest->execute('{"zarafa":{"hie...')\n#7 {main}, referer: http://192.168.123.9/webapp/

??

bskoeln

Is is “only” one client getting this error?

CentOS 7.4.1708
Mariadb-5.5.56-2
KC 8.5.4.0-9.1
WebApp 3.4.5.1202-47.1 external Server - TCP-Socket
Z-Push 2.3.9+0-90.1
PHP-MAPI 8.5.4.0-9.1
PHP 5.6.25 with Zend OPcache v7.0.6-dev
DeskApp 1.5.0
Outlook 2016(64bit) KOE 1.6.282
Outlook 2010 -Zarafa 7.2.6

looking in older apache error logs this error appears sometimes with various clients…

But this client ist the only not syncing…so far…

which version of “kopano-server”, “z-push”, “php-mapi” and “libkcmapi” are you using?

CentOS 7.4.1708
Mariadb-5.5.56-2
KC 8.5.4.0-9.1
WebApp 3.4.5.1202-47.1 external Server - TCP-Socket
Z-Push 2.3.9+0-90.1
PHP-MAPI 8.5.4.0-9.1
PHP 5.6.25 with Zend OPcache v7.0.6-dev
DeskApp 1.5.0
Outlook 2016(64bit) KOE 1.6.282
Outlook 2010 -Zarafa 7.2.6

Kopano is 8.3.2.15 with php5-mapi Z-push is 2.3.7

t here are updates for both available:
depends on your environment kopano update
z-push is 2.4 availöable (now on next active sync protocoll), for testing i would suggest first install 2.3.9

information abour your system (distribution) and outlook version (with 32/64 bit) and KOE version would be grate aswell

coffee_is_life

CentOS 7.4.1708
Mariadb-5.5.56-2
KC 8.5.4.0-9.1
WebApp 3.4.5.1202-47.1 external Server - TCP-Socket
Z-Push 2.3.9+0-90.1
PHP-MAPI 8.5.4.0-9.1
PHP 5.6.25 with Zend OPcache v7.0.6-dev
DeskApp 1.5.0
Outlook 2016(64bit) KOE 1.6.282
Outlook 2010 -Zarafa 7.2.6

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.