Emails don't end up in inbox when using fetchmail plugin

I previously posted this on the issues page of the fetchmail plugin github repository but so far no one replied, so i thought that maybe I would have more luck here.

I’ve setup a Univention Corporate Server with Fetchmail and Kopano. Local mail delivery is working just fine and i can also receive messages from one of my other mailboxes if I input the settings in the remote mail retrieval option in Univention Management Console which is enabled when you install Fetchmail.

The issue I’m having is that when the daemon of the fetchmail plugin is running it polls the emails from the remote mailbox but they don’t end up in my local mailbox.
Logic suggests that the issue is with local mail delivery but as I said before, it works just fine if the daemon is not running.

Here’s the screenshot of the polling https://pasteboard.co/HcEnXBd.png
And here the log from Postfix https://pastebin.com/4ktrHKaN

I’m using UCS 4.3-0 with Fetchmail 6.3.26 over http. Any help would be greatly appreciated.

Mar 19 17:23:15 www2 postfix/local[33844]: F23373E82F70: to=<dilma.francisco@localhost>, relay=local, delay=0.02, delays=0.02/0.01/0/0, dsn=2.0.0, status=sent (delivered to mailbox)

Mails are not delivered into your Kopano mailbox, but a local mailbox on the system. Delivery should be done here to your actual email address and not something@localhost

Hi Felix. Thanks a lot for your prompt reply.

That caught my eye too but i don’t know what to do to fix it but also why does it work when the plugin daemon is not running?

I could use any suggestion u may have.

Thanks again.

@zirpco said in Emails don't end up in inbox when using fetchmail plugin:

why does it work when the plugin daemon is not running?

Probably because the Fetchmail app on Univention is delivering to the correct user.

There is a pr linked in that github issue you mentioned that sounds like it could fix your problem.

I missed that. I guess the plugin author must be out on vacation or something.

Thanks again Felix. I’ll try it and I’ll let you know if it works.

Plugin author here: Not on a vacation (I wish) - just didn’t have the time.

I merged the fix by haggybear, and will probably release a new build over the weekend.

Hi olia

I saw your reply on github but now I’m fighting with UCS which apparently messed up my kopano installation after an update. I already tried reverting the VM and reinstalling from scratch but everytime I end up with failed install of kopano core. So for now I’m off to the UCS forum.

Thanks.

Just released a new Version that should fix the Problem: https://github.com/olia-dev/kopano-webapp-fetchmail/releases/tag/1.0.2

Thanks to haggybear for contributing the fix.

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.