kopano-webapp-filesbackend-smb php7



  • Does the kopano-webapp-filesbackend-smb not work with php7

    I allways get internal server error on uploading files to smb filesbackend - with nexlcout/owncloud backend everything works

    rg
    Christian


  • Kopano

    Could your provide some information about your system.
    Such as OS, webapp, files + backends versions etc.



  • @marty

    It was Univention UCS 4.2-3
    Upgraded to UCS 4.3
    installed standard app form app-center - no repos for UCS 4.3
    kopano-core uses debian9 repo = 8.5.5
    webapp was befor upgrade 3.4.9 now 3.4.2.1108+36.1 (no repo for UCS4.3)
    z-push was 2.4.0 after upgrade 2.3.8 (no repo for UCS4.3)
    files was latest version now 2.1.0.222+34.2
    file-smb-backend is now 2.1.0.35+13.2

    rg
    Christian


  • Kopano

    @externa1 Is php-smbclient installed and activated?
    And any output in the error.log?



  • @marty

    [Mon Mar 19 15:50:44.575035 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [DBG][AccountStore] Found 3 accounts., referer:
    [Mon Mar 19 15:50:44.575098 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [DBG][BackendStore] Searching for external backends in /usr/share/kopano-webapp/plugins/, referer:
    [Mon Mar 19 15:50:44.575222 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [DBG][BackendStore] Registering backend: Webdav, referer:
    [Mon Mar 19 15:50:44.575508 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [DBG][BackendStore] Registering backend: FTP, referer:
    [Mon Mar 19 15:50:44.575702 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [DBG][BackendStore] Registering external backend: SMB, referer:
    [Mon Mar 19 15:50:44.575836 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [DBG][BackendStore] Registering external backend: Owncloud, referer:
    [Mon Mar 19 15:50:44.576202 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [DBG][FilesBrowserModule] [cache] memcached storage could not be loaded. Using files storage., referer:
    [Mon Mar 19 15:50:44.576566 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [DBG][FilesBrowserModule] [constructor]: executing the module as uid: ck, referer:
    [Mon Mar 19 15:50:44.576634 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [DBG][FilesBrowserModule] Checking: #R#832d0c0183045a8f892ed6eee9c425a7/, referer:
    [Mon Mar 19 15:50:44.576736 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [BACKEND_SMB]: Share path set to DATEN, referer:
    [Mon Mar 19 15:50:44.576792 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [BACKEND_SMB]: libsmbclient-php not available, falling back to wrapping smbclient, referer:
    [Mon Mar 19 15:50:44.576916 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [BACKEND_SMB]: SMB Share openened successfully!, referer:
    [Mon Mar 19 15:50:44.576934 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [DBG][FilesBrowserModule] Getting content for: /,
    [Mon Mar 19 15:50:44.576942 2018] [:error] [pid 89012] [client 192.168.2.32:47968] [BACKEND_SMB]: [LS] start for dir: /,
    [Mon Mar 19 15:50:48.121325 2018] [:error] [pid 89012] [client 192.168.2.32:47968] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 134217736 bytes) in /usr/share/kopano-webapp/plugins/filesbackendSMB/php/lib/SMB/src/Connection.php on line 43, referer:

    php-smbclient was not installed after installing it seems to work now

    rg
    Christian


  • Kopano

    If you use the debian9 repo for files there should be a dependency on:
    php-libsmbclient which should provide php-smbclient
    https://packages.debian.org/stretch/php-libsmbclient

    Btw, please upgrade to the latest files, it contains some important fixes:
    https://documentation.kopano.io/kopano_changelog/kfp.html#kopano-files-plugin



  • @marty said in kopano-webapp-filesbackend-smb php7:

    If you use the debian9 repo for files there should be a dependency on:
    php-libsmbclient which should provide php-smbclient

    no - i hope that repos for webapp, z-push for ucs 4.3 will be available soon from kopano

    rg
    christian



  • @externa1 Seems that I have the same problem. I have the same error-messages in log-file. I set up a new Univention 4.3 Server with Kopano Core from the kopano-repos. I hope for the repos soon too.

    rg Ari


  • Kopano

    Ucs 4.3 and Debian 9 are nearly identical, so if everything you are waiting for are repositories, you can use the Debian 9 ones instead


Log in to reply