Kopano Install on Univention UCS 4.3

Hi, I upgraded nowadays my UCS 4.2 to 4.3. After the Upgrade Kopano Webapp stopped working. :-( After hours I decided to reinstall the whole Server. Unfortunately Kopano Webapp even don’t work on a clean installation.

  • The first reason is Apacha2 PHP execution module mismatch. Kopano Webapp needs PHP7. UCS 4.3 is installing “libapache2-mod-php5”. OK, no problem, I installed “libapache2-mod-php7.0” and enabled PHP7 on Apache2
  • The next Problem is a missing “php7-mapi” configuration. Well, I reconfigured “php7-mapi” with executing “dpkg-reconfigure php7-mapi”
    After this Kopano Webapp works now on a clean installed UCS 4.3 Server.

Unfortunately, I didn’t have made a Snapshot of my Server bevor UCS 4.3 upgrade. So I had to restore my Kopano Data from backup.

Best regards,
Bruno Ploszczyca

Hi @bruno-ploszczyca ,

how did you install WebApp? From the app store? The app store WebApp has a direct dependency on the php7 variant of php-mapi to circumvent these issues.

Hi Felix,

Yes, I have installed WebApp from app Store. That’s true, WebApp has a direct dependency to php7 and all packages are in place, but obviously not to “libapache2-mod-php7.0”

UCS installs “libapache2-mod-php” instead of “libapache2-mod-php7.0”

Best Retards,
Bruno Ploszczyca

Which version of the WebApp are you running? Do you have our repositories configured additionally?

I had working installations of kopano core and web app running on UCS 4.3-0 joined to an AD domain until I installed a UCS update. After the server rebooted the web app was unable to connect to core and I was unable to reinstall kopano because it would error out while trying to connect to the database. Since then i already restored the VM to a previous checkpoint and installed everything from scratch, by deleting the domain controller master entry in the AD DNS Console and also the 2 DNS Host records (one with host name of the UCS and other with name ucs-sso) about 8 times and every single time i get this error https://pasteboard.co/Hdehuq1.png

Here’s the output of appcenter.log

11802 packages                          18-03-23 12:29:48 [    INFO]: Unpacking univention-spamassassin (9.0.0-6A~4.3.0.201803091404) ...^M
 11802 packages                         18-03-23 12:29:49 [    INFO]: Selecting previously unselected package univention-antivir-mail.^M
 11802 packages                         18-03-23 12:29:49 [    INFO]: Preparing to unpack .../162-univention-antivir-mail_9.0.0-4A~4.3.0.201801081055_all.deb ...^M
 11802 packages                         18-03-23 12:29:49 [    INFO]: Unpacking univention-antivir-mail (9.0.0-4A~4.3.0.201801081055) ...^M
 11802 packages                         18-03-23 12:29:50 [    INFO]: Selecting previously unselected package gnupg1-curl.^M
 11802 packages                         18-03-23 12:29:50 [    INFO]: Preparing to unpack .../163-gnupg1-curl_1.4.21-4_amd64.deb ...^M
 11802 packages                         18-03-23 12:29:50 [    INFO]: Adding 'diversion of /usr/lib/gnupg1/gpgkeys_curl to /usr/lib/gnupg1/gpgkeys_curl.non_curl by gnupg1-curl'^M
 11802 packages                         18-03-23 12:29:50 [    INFO]: Adding 'diversion of /usr/lib/gnupg1/gpgkeys_hkp to /usr/lib/gnupg1/gpgkeys_hkp.non_curl by gnupg1-curl'^M
 11802 packages                         18-03-23 12:29:50 [    INFO]: Unpacking gnupg1-curl (1.4.21-4) ...^M
 11802 packages                         18-03-23 12:29:50 [    INFO]: Selecting previously unselected package gnupg1-l10n.^M
 11802 packages                         18-03-23 12:29:50 [    INFO]: Preparing to unpack .../164-gnupg1-l10n_1.4.21-4_all.deb ...^M
 11802 packages                         18-03-23 12:29:50 [    INFO]: Unpacking gnupg1-l10n (1.4.21-4) ...^M
 11802 packages                         18-03-23 12:29:51 [    INFO]: Errors were encountered while processing:^M
 11802 packages                         18-03-23 12:29:51 [    INFO]:  /tmp/apt-dpkg-install-ug547U/047-kopano-common_8.4.5.0-0+33.2_amd64.deb^M
 11802 packages                         18-03-23 12:29:51 [ WARNING]: E: Sub-process /usr/bin/dpkg returned an error code (1)
 11802 actions.install.progress         18-03-23 12:29:51 [   DEBUG]: 80
 11802 packages                         18-03-23 12:29:51 [   DEBUG]: Releasing LOCK
 11802 actions.install                  18-03-23 12:29:51 [CRITICAL]: Failed to install the App
 11802 actions.install                  18-03-23 12:29:51 [ WARNING]: Aborting...
 11802 actions.remove                   18-03-23 12:29:51 [   DEBUG]: Calling remove
 11802 actions.remove.progress          18-03-23 12:29:51 [   DEBUG]: 0
 11802 actions.remove                   18-03-23 12:29:51 [    INFO]: Going to remove Kopano Core (8.4.5.0)
 11802 actions.remove                   18-03-23 12:29:52 [    INFO]: (must_not_have_concurrent_operation) Another package operation is in progress
 11802 actions.remove                   18-03-23 12:29:52 [   DEBUG]: Calling prescript (prerm)
 11802 actions.remove                   18-03-23 12:29:52 [   DEBUG]: /var/cache/univention-appcenter/appcenter.software-univention.de/4.3/kopano-core_20180102102306.prerm does not exist
 11802 packages                         18-03-23 12:29:52 [   DEBUG]: Holding LOCK
 11802 actions.remove                   18-03-23 12:29:52 [    INFO]: No hostdn for kopano-core found. Nothing to remove
 11802 actions.remove.progress          18-03-23 12:29:52 [   DEBUG]: 5
 11802 actions.configure                18-03-23 12:29:52 [   DEBUG]: Calling configure
 11802 actions.configure.progress       18-03-23 12:29:52 [   DEBUG]: 0
 11802 actions.configure                18-03-23 12:29:52 [    INFO]: Configuring kopano-core=8.4.5.0
 11802 actions.configure                18-03-23 12:29:52 [   DEBUG]: /var/cache/univention-appcenter/appcenter.software-univention.de/4.3/kopano-core_20180102102306.configure_host does not exist
 11802 actions.configure.progress       18-03-23 12:29:52 [   DEBUG]: 100
 11802 packages                         18-03-23 12:29:52 [   DEBUG]: Calling /usr/bin/apt-get -o DPkg::Options::=--force-confold -o DPkg::Options::=--force-overwrite -o DPkg::Options::=--force-overwrite-dir --trivial-only=no --assume-yes --auto-remove remove kopano4ucs
 11802 packages                         18-03-23 12:29:52 [    INFO]: Reading package lists...
 11802 packages                         18-03-23 12:29:52 [    INFO]: Building dependency tree...
 11802 packages                         18-03-23 12:29:52 [    INFO]: Reading state information...
 11802 packages                         18-03-23 12:29:52 [    INFO]: You might want to run 'apt --fix-broken install' to correct these.
 11802 packages                         18-03-23 12:29:52 [    INFO]: The following packages have unmet dependencies:
 11802 packages                         18-03-23 12:29:52 [    INFO]:  kopano-backup : Depends: kopano-common but it is not going to be installed
 11802 packages                         18-03-23 12:29:52 [    INFO]:  kopano-dagent : Depends: kopano-common (= 8.4.5.0-0+33.2) but it is not going to be installed
 11802 packages                         18-03-23 12:29:52 [    INFO]:  kopano-gateway : Depends: kopano-common (= 8.4.5.0-0+33.2) but it is not going to be installed
 11802 packages                         18-03-23 12:29:52 [    INFO]:  kopano-ical : Depends: kopano-common (= 8.4.5.0-0+33.2) but it is not going to be installed
 11802 packages                         18-03-23 12:29:52 [    INFO]:  kopano-monitor : Depends: kopano-common (= 8.4.5.0-0+33.2) but it is not going to be installed
 11802 packages                         18-03-23 12:29:52 [    INFO]:  kopano-presence : Depends: kopano-common but it is not going to be installed
 11802 packages                         18-03-23 12:29:52 [    INFO]:  kopano-server : Depends: kopano-common (= 8.4.5.0-0+33.2) but it is not going to be installed
 11802 packages                         18-03-23 12:29:52 [    INFO]:  kopano-spooler : Depends: kopano-common (= 8.4.5.0-0+33.2) but it is not going to be installed
 11802 packages                         18-03-23 12:29:52 [ WARNING]: E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
 11802 packages                         18-03-23 12:29:53 [   DEBUG]: Releasing LOCK
 11802 actions.remove                   18-03-23 12:29:53 [CRITICAL]: Failed to uninstall the App
 11802 actions.remove                   18-03-23 12:29:53 [ WARNING]: Aborting...
 11802 actions.remove                   18-03-23 12:29:53 [    INFO]: File: /usr/share/univention-management-console/modules/apps.xml
 11802 actions.remove                   18-03-23 12:29:53 [    INFO]:
 11802 actions.remove                   18-03-23 12:29:54 [    INFO]: File: /usr/share/univention-management-console/i18n/de/apps.mo
 11802 actions.remove                   18-03-23 12:29:54 [    INFO]:
 11802 actions.remove                   18-03-23 12:29:55 [    INFO]: Module: kopano-cfg
 11802 actions.remove                   18-03-23 12:29:55 [    INFO]:
 11802 actions.remove                   18-03-23 12:29:55 [    INFO]: File: /etc/apt/apt.conf.d/55user_agent
 11802 actions.remove                   18-03-23 12:29:55 [    INFO]:
 11802 actions.upgrade-search           18-03-23 12:29:55 [   DEBUG]: Calling upgrade-search
 11802 actions.upgrade-search.progress  18-03-23 12:29:55 [   DEBUG]: 0

It seems that the problem lies in the kopano-common binary package.

When i run apt --fix-broken install as instructed i get the following:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  kopano-common
The following NEW packages will be installed:
  kopano-common
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
173 not fully installed or removed.
Need to get 0 B/25.0 kB of archives.
After this operation, 79.9 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 88088 files and directories currently installed.)
Preparing to unpack .../kopano-common_8.4.5.0-0+33.2_amd64.deb ...
passwd: user 'kopano' does not exist in /etc/passwd
dpkg: error processing archive /var/cache/apt/archives/kopano-common_8.4.5.0-0+3       3.2_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/kopano-common_8.4.5.0-0+33.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Is there an issue with the repository or am I missing something?

This post is deleted!

@zirpco said in Kopano Install on Univention UCS 4.3:

Is there an issue with the repository or am I missing something?

I don’t have a testsystem that is part of an active directory, but in my test environment I can install the core app just fine.

Tried a couple times again with same results, so i gave up.
I’m trying another groupware called SOGo.

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.