Z-Push FatalMisconfigurationException

Good Morning @yythoss,

what about the rights on this file? Maybe its all set and valid, but can’t be accessd

coffee_is_life

This are the rights:

-rw-r----- 1 root z-push  3735  8. Mär 20:53 kopano.conf.php
-rw-r----- 1 root z-push  7855  8. Mär 20:53 policies.ini
-rw-r----- 1 root z-push 20116  8. Mär 20:53 z-push.conf.php

seems all right…

what does z-push and your webserver logs say? - maybe incrase the verbosity ( define(‘LOGLEVEL’, LOGLEVEL_DEBUG); )

At this moment, no logfile from z-push exist.
I have change the loglevel to:

define('LOGUSERLEVEL', LOGLEVEL_DEBUG);

Apache ssl_error.log say:

[Wed Mar 14 10:24:11.501104 2018] [:error] [pid 7767] [client 192.168.201.89:52459] PHP Notice:  Use of undefined constant LOGBACKEND_CLASS - assumed 'LOGBACKEND_CLASS' in /usr/share/z-push/lib/core/zlog.php on line 141
[Wed Mar 14 10:24:11.501117 2018] [:error] [pid 7767] [client 192.168.201.89:52459] The configured logging class `LOGBACKEND_CLASS` does not exist. Check your configuration.
[Wed Mar 14 10:24:11.501140 2018] [:error] [pid 7767] [client 192.168.201.89:52459] The configured logging class `LOGBACKEND_CLASS` does not exist. Check your configuration.

Now I have change the right to 755:

 chmod 755 /etc/z-push/*

Now I can login with the webbrowser, but I the this message:

Z-Push - Open Source ActiveSync
Version 2.4.0+0
GET not supported
This is the Z-Push location and can only be accessed by Microsoft ActiveSync-capable devices

Is this all OK?

This is all ok

@yythoss said in Z-Push FatalMisconfigurationException:

Now I have change the right to 755

that seems a bit excessive. Normally the user of the webserver should be included in the z-push group now. Can you check if that is the case for your setup?

In our CentOS installation the httpd24 user is not apache, it is www.
I add this user www to the z-push group, but the same error, when I use the old right of the config.php

Sorry, I forgot to restart Apache, now it works. You are right.
THX

as its the case for changed groups the user needs to relogin for the changes to be applied. so you need to restart your webserver.

edit: ah you realised that as well already