Z-push 2.4 with Zimbra backend

Hi, I mistakenly upgraded to z-push 2.4 that was released yesterday and now seems my zimbra backend v67 does not work any more … do I need to tweak something ?
Do we need to wait for backend v68 ? Or maybe is something else

The error I get is

Fatal error: /usr/share/z-push/backend/zimbra/zimbra.php:12843 - Declaration of BackendSearchZimbra::GetGALSearchResults() must be compatible with ISearchProvider::GetGALSearchResults($searchquery, $searchrange, $searchpicture) (64)

Thanks for any advise

Yes, the IBackend interface changed in 2.4.
@liverpoolfcfan any plans on updating?

I would say you could immediately downgrade to 2.3.9, there is an old-final repository available.
This should get it working again.

I have created a bug report on sourceforge :
https://sourceforge.net/p/zimbrabackend/bugs/76/

I have provided a workaround

Regards

@sebastian said in Z-push 2.4 with Zimbra backend:

Yes, the IBackend interface changed in 2.4.
@liverpoolfcfan any plans on updating?

I would say you could immediately downgrade to 2.3.9, there is an old-final repository available.
This should get it working again.

Yes. I have already added the parameter in my local respository. It is just not released as yet.