sendas issue

I added a user via kopano-cli with --add-sendas but i get following error in spooler.log

HRESULT SMTPToZarafa(LPADRBOOK, ULONG, const ENTRYID*, ULONG*, ENTRYID**): ResolveName failed: not found (8004010f)
User "xyz" is not allowed to send as user or group "xxx@fqdn". You may enable all outgoing addresses by enabling the always_send_delegates option.

I’m wondering it lists the user@fqdn but not the “%u” value.

Running Version 8.5.4.0-0+9.1.

Thanks,
Heiko

Hello @HBO ,

thanks for your report. I tried this but it works for me on 8.5.4.0-0+9.1, Debian 8 and the db plugin.

Hi @fbartels

i made some new tests:

  • Sendas with Kopano Webapp and Deskapp works fine
  • Sendas with Outlook works with seperated added accounts
  • Sendas with Outlook doesn’t work with OL Extension and added account inbox/Folders from other accounts

Thanks,
Heiko

Did you enable the send as flag when you’ve added the share?
Is the GAB correctly synchronized to Outlook?
You need both for send as via KOE to work.

I got a GAB but with a very old state, “z-push-gabsync -a sync” helped out (and added this as daylie cron).
Thanks for this hint.

Little new issue:

Created a account “test” with secretary access on account “test2”

  • It’s possible to send as “test” from mails in test2 inbox without set sendas anywhere within Outlook and Kopano
  • Send as “test2” works fine within shared object

Is it a bug or configuration problem? Some users shouldn’t be allowed to send as their own user from a shared object.

@hbo said in sendas issue:

Send as “test2” works fine within shared object

can you add some more details to this? Is this still in Outlook/KOE? what is a “shared object” in this case?

Are you by any chance talking about a calendar item? If so then this is an intentional default (so you can forward meeting requests and the original organiser still can get updates for this). If not desired then this can be changed in spooler.cfg by setting

# Allow to forward and sent a meeting request as delegate Kopano and
# SMTP user.
allow_delegate_meeting_request = no

Tested with Kopano Webapp and Outlook KOE.

Issue with Webapp:
Logged in with User “test” and added “Shared mails” from account “test2” (Inbox and subfolders). User “test” got secretary rights on Inbox from user “test2”. There is no “send as” delegation an configuration on user “test2”.
I can answer on mails in inbox “test2” from both user, mails from user “test” are not rejected

Issue with Outlook/KOE:
It’s possible to uncheck “send from owner” by adding the shared inbox. Mails from this shared inbox are send by origin user “test” and not rejected.

We’ve got some group email addresses like info@domain.tld with an own account. All users got secretary rights on this account and have to send new mails and answers from this account only with it’s configured email adress. But it’s possible as descriped to send as their own user.

@hbo said in sendas issue:

I can answer on mails in inbox “test2” from both user, mails from user “test” are not rejected

I am not able to reproduce this. I get the expected “You are not allowed to send as user or group” mail. Have you maybe set the delegation settings in WebApp for this combination?

@hbo said in sendas issue:

Mails from this shared inbox are send by origin user “test” and not rejected.

yes, that is by design. If you reply from a folder with your own address as the from you will just send this email as yourself.

There was a delegation setting in WebApp and works fine now, thanks.

Is there any possibility to prevent users from changing the “sendas owner” setting in Outlook KOE addon?

@hbo said in sendas issue:

Is there any possibility to prevent users from changing the “sendas owner” setting in Outlook KOE addon?

No, KOE does not offer such a functionality. And even if we would implement this the user could still in the email itself change the “from” value.