Auth issues with IMAP Backend // Dovecot



  • I’m able to access the /Microsoft-Server-ActiveSync URL however regardless what is entered as username logs show user as Unknown. Backend is IMAP via Dovecot.

    Any idea?

    05/03/2018 12:01:31 [ 3827] [DEBUG] [unknown] [] -------- Start
    05/03/2018 12:01:31 [ 3827] [DEBUG] [unknown] [] cmd='' devType='' devId='' getUser='unknown' from='1.1.1.1' version='2.3.9+0' method='GET'
    05/03/2018 12:01:31 [ 3827] [ INFO] [unknown] [] AuthenticationRequiredException: Access denied. Please send authorisation information - code: 0 - file: /usr/share/z-push/index.php:56
    05/03/2018 12:01:31 [ 3827] [ INFO] [unknown] [] User-agent: 'unknown'
    05/03/2018 12:01:31 [ 3827] [FATAL] [unknown] [] Exception: (AuthenticationRequiredException) - Access denied. Please send authorisation information
    05/03/2018 12:01:31 [ 3827] [DEBUG] [unknown] [] ZPush::PrintZPushLegal()
    05/03/2018 12:01:31 [ 3827] [DEBUG] [unknown] [] TopCollector(): Initialized mutexid Resource id #40 and memid Resource id #41.
    05/03/2018 12:01:31 [ 3827] [DEBUG] [unknown] [] TopCollector initialised with IPC provider 'IpcSharedMemoryProvider' with type '20'
    05/03/2018 12:01:31 [ 3827] [ INFO] [unknown] [] cmd='' memory='2.24 MiB/2.50 MiB' time='0.02s' devType='' devId='' getUser='unknown' from='1.1.1.1' idle='0s' version='2.3.9+0' method='GET' httpcode='401'
    05/03/2018 12:01:31 [ 3827] [DEBUG] [unknown] [] -------- End
    

  • Kopano

    It seems as all the GET parameters are missing. No command, devtype, devid etc.
    How did you setup your webserver? Are the GET parameters being passed to the script?



  • Thanks that got me in the right direction. It was due to PHP set as FastCGI.


Log in to reply