localized folder names



  • Hello,

    I updated my kopano installation to core-8.5.81.286 on ubuntu 16.04

    When I create new users all folder names are english - not german like it was before.

    These are the settings in /etc/default/kopano

    KOPANO_LOCALE="de_DE.UTF-8"
    KOPANO_USERSCRIPT_LOCALE="de_DE.UTF-8"
    

    And outputs:

    locale
    
    LANG=de_DE.UTF-8
    LANGUAGE=
    LC_CTYPE="de_DE.UTF-8"
    LC_NUMERIC="de_DE.UTF-8"
    LC_TIME="de_DE.UTF-8"
    LC_COLLATE="de_DE.UTF-8"
    LC_MONETARY="de_DE.UTF-8"
    LC_MESSAGES="de_DE.UTF-8"
    LC_PAPER="de_DE.UTF-8"
    LC_NAME="de_DE.UTF-8"
    LC_ADDRESS="de_DE.UTF-8"
    LC_TELEPHONE="de_DE.UTF-8"
    LC_MEASUREMENT="de_DE.UTF-8"
    LC_IDENTIFICATION="de_DE.UTF-8"
    LC_ALL=
    
    locale -a
    
    C
    C.UTF-8
    de_AT.utf8
    de_BE.utf8
    de_CH.utf8
    de_DE.utf8
    de_LI.utf8
    de_LU.utf8
    en_AG
    en_AG.utf8
    en_AU.utf8
    en_BW.utf8
    en_CA.utf8
    en_DK.utf8
    en_GB.utf8
    en_HK.utf8
    en_IE.utf8
    en_IN
    en_IN.utf8
    en_NG
    en_NG.utf8
    en_NZ.utf8
    en_PH.utf8
    en_SG.utf8
    en_US.utf8
    en_ZA.utf8
    en_ZM
    en_ZM.utf8
    en_ZW.utf8
    POSIX
    

    Can someone help me out to change it back?
    Thanks a lot!



  • Hej l4k3k3m4n .

    What is the output of

    kopano-admin -l
    

    ?

    Are there Users having “German Umlaut’s” in it, and they are shown correctly?

    Maybe you should set your Web-Servers configuration to de_DE.UTF-8

    Apache2 file is called “envvars” (located in directory /etc/apache2/ in Debian).
    You should comment out:

    ## The locale used by some modules like mod_dav
    ## export LANG=C
    
    ## Uncomment the following line to use the system default locale instead:
    ## . /etc/default/locale
    

    …and add

    export LANG=de_DE.UTF-8
    

    Restart Web-Server.

    So you can use english (en_US.UTF-8) as Server default language (my preffered language for server).

    Maybe this helps ;-)

    Regards
    Marcus



  • Hello Marcus,

    thanks for your help.
    Apache is set to system default locale.

    I installed a fresh kopano test system and have the following observation:

    I create a user:

    kopano-cli --create --user "robin.mueller" --fullname="Robin Müller" --email="robin@mueller.de" --password="1234" --admin-level=0
    

    This is the result:

    kopano-cli --list-user
    User list for Default (2):
                User           Full Name          Homeserver                                   Store
    ------------------------------------------------------------------------------------------------
              SYSTEM              SYSTEM              Kopano        8962FFEFFB7B4D639BC5967C4BB58234
       robin.mueller       Robin Müller              Kopano        4AD937BBEE444FBBBB5CA59D1F6C5D45
    

    And here we have a screenshot from the webapp:
    0_1518599383560_Unbenannt.JPG

    One week ago all worked well without problems.
    How can I change this behaviour?

    Thanks



  • Look at your /etc/default/kopano file, setting: KOPANO_USERSCRIPT_LOCALE=“de_DE.UTF-8”
    is this set at German?



  • Hej l4k3k3m4n .

    Please post your system…

    Linux-Version…Kopano-Version a.s.o…



  • This is in /etc/default/kopano

    KOPANO_LOCALE="de_DE.UTF-8"
    KOPANO_USERSCRIPT_LOCALE="de_DE.UTF-8"
    

    I am running

    Distributor ID: Ubuntu
    Description:    Ubuntu 16.04.3 LTS
    Release:        16.04
    Codename:       xenial
    
    WebApp 3.4.6.1233+718.1
    Kopano Core 8.5.81
    


  • @l4k3k3m4n

    …change your

    /etc/apache2/envvars
    

    …like described, if you use Apache, and restart your webserver

    Maybe it is a bug in WebApp.

    Curretly i use:

    WebApp: 3.4.5.1200+703.1
    Kopano Core: 8.5.81



  • Changing envars in apache does not make a difference.

    I can use this script to rename the folders:

    https://stash.kopano.io/projects/KSC/repos/core-tools/browse/localize-folders

    After that the folder names are right.
    So I dont think this can be a webapp bug. There must be something wrong during folder creation process.



  • @l4k3k3m4n

    Hmm…okay.

    There is another difference…

    You use kopano-cli
    …i use kopano-admin

    Could you try to create a new user with kopano-admin and see what happens?
    Should be the same…but, who knows… ;o)

    Looks like kopano-admin is a binary and kopano-cli a Python-Script

    # file kopano-admin
    kopano-admin: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV)
    
    # file kopano-cli
    kopano-cli: Python script, ASCII text executable
    
    # cat kopano-cli
    #!/usr/bin/env python2
    import sys
    import kopano_cli
    from kopano_cli import __version__
    
    if __name__ == '__main__':
        sys.exit(kopano_cli.main())
    


  • Its the same behaviour with kopano-cli and kopano-admin.


  • Kopano

    Are the folder names now in english (like the opening post claims) or german, but with broken umlauts (as the screenshot shows)?

    If the first, then /etc/default/kopano is the solution to have new stores created in the correct language.
    if the latter then there is still php which could mingle the umlauts and should also be supplied with the correct locales.



  • Hello @l4k3k3m4n,

    i got the exact same problem in the past, my fix was to rely on the case sensitive utf8.

    your “locale -a” shows

    de_DE.utf8
    

    so set the /etc/sysconfig/kopano setting to "KOPANO_LOCALE=“de_DE.utf8” and "KOPANO_USERSCRIPT_LOCALE=“de_DE.utf8"”
    not “de_DE.UTF8” or “de_DE.UTF-8” (note the dash)

    this should do it. In some cases its useful to rename all folders to english and back to german with your mentioned script

    coffee_is_life