Recieved Mails

Hi,

I noticed that in the new version only the first 3 letters of a day is displayed
in the “Recvied Field” (see attachment) instead of the full name. Is that work
as designed?

Regards
0_1518028110165_recieved.PNG

Yes.
You can change it back to the old dates in settings.
General settings -> Display