Error updating Kopano 8.4.5 to 8.4.99



  • Hi,

    maybe somebody can help me.
    We are running Kopano Core on a CentOS 7.4 server with PHP 5.6 SCL installed.

    When I try to update the server I get the errors below, can anybody tell me what’s going on?

    Kind regards,
    Cor van den berghe.

    Error: Package: libkchl0-8.4.5.0-33.1.x86_64 (@Kopano-Core)
               Requires: libkcmapi.so.0(KC_8.4)(64bit)
               Removing: libkcmapi0-8.4.5.0-33.1.x86_64 (@Kopano-Core)
                   libkcmapi.so.0(KC_8.4)(64bit)
               Updated By: libkcmapi0-8.4.99.0-6.1.x86_64 (Kopano-Core_RC)
                   Not found
    Error: Package: libkchl0-8.4.5.0-33.1.x86_64 (@Kopano-Core)
               Requires: libmapi.so.1(KC_8.4)(64bit)
               Removing: libmapi1-8.4.5.0-33.1.x86_64 (@Kopano-Core)
                   libmapi.so.1(KC_8.4)(64bit)
               Updated By: libmapi1-8.4.99.0-6.1.x86_64 (Kopano-Core_RC)
                   Not found
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    

  • Kopano

    Hi @acha ,

    I was able to reproduce your message. I have created https://jira.kopano.io/browse/KC-1004 to investigate and resolve.



  • Hello @Felix,

    similar problem when I try to update kopano from 8.4.5.0-33.1 to 8.5.3.0-18.1 on SLES 12 SP2.

    YaST2 Software says:
    kopano-client-8.5.3.0-18.1.x86_64 requires libkcmapi.so.0(KC_8.5)(64bit), but this requirement cannot be provided

    Repository: Kopano_Core_SLES_12_PHP7

    I have seen you are working on a resolution. Could you say when fix would be available?

    Regards Ulrich


  • Kopano

    Hi @dylan08 ,

    from the development side this was supposed to be resolve, hence the qa state.



  • Hello Felix,

    I have seen that it is in QA state.
    Do you know when the next stable release will be available?

    Regards Ulrich



  • Hello,

    i had the same issue in serveral previous updates…

    fixedc for me was to do something like this:

    yum whatprovides *libkcserver*
    

    now i know which package is delivering it and did a “yum update”

    it showed me, that a “libmapi” is ready for install

    i think this should be a dependencie in kopano-server, so if i use “yum update kopano*” it should update automaticly

    for a workaround just do a normal update. the package is availible

    (i use centos 7 - so for other distrebutions there is obviously another command usage way)

    coffee_is_life


  • Kopano

    @dylan08 said in Error updating Kopano 8.4.5 to 8.4.99:

    Do you know when the next stable release will be available?

    what kind of release are you looking for? 8.5.x or 8.6?



  • Hello,

    currently installed: 8.4.5.0
    I would like to update to 8.5.5.0

    Regards
    Ulrich


  • Kopano

    That one is available since a few hours



  • Hello,

    thank you. I have seen that the new release is available in YaST2. Will try to update this weekend.

    Regards
    Ulrich



  • Hello,

    after I have deleted one dependency in YaST kopano 8.5.5 installed with no problem.
    Couldn’t remember exactly which old package I have to delete. Something like libkc… :-(

    The new version is working as expected.

    Regards
    Ulrich



  • Hi,

    Just did an update to version 8.5.5 and worked like a charm. For as far as I’m concerned this issue is fixed and can be closed (or marked as solved)

    Thanks for your help!

    Regards,
    Cor.


  • Kopano

    Hi @acha ,

    thanks for the feedback.


Log in to reply