[SOLVED] search.log errors MAPI_E_DISK_ERROR

Running kopano version 8.3.0.999 for a while without trouble.

Now getting the following error every 5 seconds in search.log
Nothing else in my logs.

Ubuntu 16.4

Tried rebuilding on a new server from source - same problem when I import my existing database and attachments. No obvious problems elsewhere - webapp &c all work.

Any ideas?

2018-01-22 15:14:19,812 - search - ERROR - Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/kopano/log.py”, line 89, in log_exc
try: yield
File “/usr/lib/python2.7/dist-packages/kopano_search/init.py”, line 382, in incremental_sync
new_state = self.server.sync(importer, self.state, log=self.log)
File “/usr/lib/python2.7/dist-packages/kopano/server.py”, line 688, in sync
return _ics.sync(self, self.mapistore, importer, state, log or self.log, max_changes, window=window, begin=begin, end=end, stats=stats)
File “/usr/lib/python2.7/dist-packages/kopano/ics.py”, line 215, in sync
exporter.Config(stream, flags, importer, restriction, None, None, 0)
File “/usr/lib/python2.7/dist-packages/MAPICore.py”, line 1902, in Config
return _MAPICore.IExchangeExportChanges_Config(self, lpStream, ulFlags, lpUnk, lpRestriction, lpIncludeProps, lpExcludeProps, ulBufferSize)
MAPIErrorDiskError: MAPI error 80040116 (MAPI_E_DISK_ERROR)

Hi @bilkusg ,

did you “rebuild” your server with the same kopano packages as the old one? Seeing that your version of the master packages are already quite old updating to the lastest version probably does not hurt.

You mention importing your database and attachments, did you also import your search index? If yes, then I would recommend dropping the search index and letting search do a fresh index.

If search logs a disk error, this means that he fails to read something from the search index.

@fbartels
Thanks for the response. The clue turned out to be in the comments about the search index - for some reason the permissions had got messed up on that directory.

It would be nice if the error message gave a clue as to the place on disk where the problem occurred! That way I would have tracked this down myself in no time.

But thanks for your help.

Gary