Kopano-Gateway-nopass



  • Hello Forum,

    since Zarafa, we are using an external mailarchiv. It will authenticate via a copied version of kopano-gateway.service, started with another konfig ("-F /etc/kopano/gateway-nopass") on another port with option “bypass_auth = yes” and another log-file.

    After about one week working without problems, the log will tell me:

    Fri Dec 29 16:00:06 2017: [error  ] [11294] M4LMsgServiceAdmin::ConfigureMsgService() MSGServiceEntry failed 80040111: logon failed
    Fri Dec 29 16:00:06 2017: [crit   ] [11294] CreateProfileTemp(): ConfigureMsgService failed 80040111: logon failed
    Fri Dec 29 16:00:06 2017: [warning] [11294] CreateProfileTemp failed: 80040111: logon failed
    Fri Dec 29 16:00:06 2017: [warning] [11294] Failed to login from <ip>:46726 with invalid username "mailarchiv" or wrong password. Error: 0x80040111
    

    i need to restart the service that everything is fine again. - But why does it even try to check username and/or password?

    There was an update in the past where this option (bypass_auth) was updated or implemented. it was around this time the error occured once.
    i’ve turned on the Info-Logging and will try to deliver more informations.

    coffee_is_life


  • Kopano

    @coffee_is_life said in Kopano-Gateway-nopass:

    After about one week working without problems, the log will tell me:

    Wonder if the logs are rotated there so the a kill -HUP is issued on the gateway, maybe leading it to reload the wrong configuration file? Just looked briefly in the code, it should load the same config file as it was started with, but maybe something got wrong. To test you could maybe set server_hostname_greeting in one of the config files to be true and false in the other.



  • Hello @bosim,

    i will try that, but to mention that i changed the .service file (/etc/systemd/system/multi-user.target.wants/kopano-gateway-nopass.service) to:

    [Service]
    Type=simple
    Environment=LC_ALL=C LANG=C
    ExecStart=/usr/sbin/kopano-gateway-nopass -F -c /etc/kopano/gateway-nopass.cfg
    ExecReload=/bin/kill -HUP $MAINPID
    
    [Install]
    WantedBy=multi-user.target
    

    coffee_is_life


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.