Deskapp unable to connect

Hello

I have installed from sources Kopano core 8.4.90, Webapp , 3.4.2 and deskapp 1.5.440 or deskapp 1.6.255
I am able to connect with kopano-Webapp but unable to connect with deskapp; I can save parameters but when I start to connect, Deskapp runs continuouly with login page and no connection.

To Connect I have to modify index.php in the kopano-webapp by adding the “/”

156 header('Location: ’ . dirname($_SERVER[‘PHP_SELF’]) . ’ / ', true, 303);
157 die();
158 }

The orginal line is the following

header('Location: ’ . dirname($_SERVER[‘PHP_SELF’]) , true, 303);

I do not know if this modification can do other thing

Any idea ?

Thank you
René

Hello @rpatw,

download and install deskapp-devel, start it and press F12 to open console.

Maybe there is a hint what deskapp is trying to do.

coffee_is_life

CentOS 7.4.1708
Mariadb-5.5.56-2
KC 8.5.4.0-9.1
WebApp 3.4.5.1202-47.1 external Server - TCP-Socket
Z-Push 2.3.9+0-90.1
PHP-MAPI 8.5.4.0-9.1
PHP 5.6.25 with Zend OPcache v7.0.6-dev
DeskApp 1.5.0
Outlook 2016(64bit) KOE 1.6.282
Outlook 2010 -Zarafa 7.2.6

Hello @Coffee_is_life

I have install deskapp level.

This is the console result when it blocks

main.js:385 Loading WebApp
main.js:508 current version:undefined
main.js:509 last version:undefined
main.js:520 App cache cleared.

This is the console result when I can connect

Loading WebApp
main.js:508 current version:undefined
main.js:509 last version:null
windows.js:47 exec error: Error: spawn C:\Users\admin\Desktop\DESKAPPSRC\NWJ\nwjs-sdk-v0.27.2-win-x64\nwjs-sdk-v0.27.2-win-x64\deskapphelper.exe ENOENT

With the deskapp devel, when I reset the profile, enter the same informations I am able to connect

Perhaps the user profile not correctly saved ?

Thanks for any help

René

Hello @rpatw

did you just installed deskapp or are you using any ini file to deploy some informations?

in my case i use an ini, that will recrate the profile everytime when deskapp is started:

forceImport=true
[general]
autoLogin=true
defaultProfile=profile_1
hideOnMinimize=true

[profiles.profile_1]
id=profile_1
name=${USERNAME}
rememberPassword=true
authType=webapp
url=<webapp-server-url>/webapp/index.php?logon
username=${USERNAME}

and for using the ini-file i’ve got a reg file:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Kopano\Kopano DeskApp]
"askForDefaultApp"=dword:00000000
"importINI"="\\\\<central-server>\\kopano-deskapp\\deskapp.ini"

this will cause deskapp to search for “deskapp.ini” and the first line “forceImport=true” force to load the ini everytime even if an active profile is found.

coffee_is_life

CentOS 7.4.1708
Mariadb-5.5.56-2
KC 8.5.4.0-9.1
WebApp 3.4.5.1202-47.1 external Server - TCP-Socket
Z-Push 2.3.9+0-90.1
PHP-MAPI 8.5.4.0-9.1
PHP 5.6.25 with Zend OPcache v7.0.6-dev
DeskApp 1.5.0
Outlook 2016(64bit) KOE 1.6.282
Outlook 2010 -Zarafa 7.2.6

Hi Coffee_is_life,

Deskapp is installed using package file. No ini file used for profile.

I will try to use an ini file

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.