php mapi for php7.0



  • Hi all,

    sorry my stupid question, but somebody can help me moving from php5 to php7.0 (Debian Stretch)?

    I do not see any possibility to install php7-mapi on my system, I just have php5-mapi.
    For this reason, I’m not able to switch my apache server to php7.0 (via a2enmod php7.0), because then the webapp is complaining mapi extension is not installed.

    My php7.0 version is 20151012, so a manual copy of mapi.so from version 20131226 does not work.

    Any help highly apreciated, I would love to get rid of php5.
    thanks
    scheini


  • Kopano

    Hello @scheini72 ,

    please always include the exact versions you are currently using in your posts (e.g. from dpkg -l). Looking into list of packages we provide for Debian 9 there actually is only a php7-mapi package, but no php5-mapi one.



  • Hi Felix,

    I just updated to the most actual version Kopano-Core 8.4, Kopano-Webapp 3.3

    dpkg -l kopano-webapp
    ||/ Name                        Version            Architektur        Beschreibung
    +++-===========================-==================-==================-============================================================
    ii  kopano-webapp               3.3.1.628-26.1     all                New and improved WebApp for Kopano
    

    my source lists are

    deb https://serial:<>@download.kopano.io/supported/files:/pre-final//Debian_8.0/ ./
    deb https://serial:<>@download.kopano.io/supported/core:/final/Debian_8.0/ ./
    deb https://serial:<>@download.kopano.io/supported/mdm:/final/Debian_8.0/ ./
    deb https://serial:<>@download.kopano.io/supported/webapp:/final/Debian_8.0/ ./
    deb https://serial:<>@download.kopano.io/supported/webmeetings:/final/Debian_8.0/ ./
    deb https://serial:<>@download.kopano.io/supported/smime:/final/Debian_8.0/ ./
    deb https://serial:<>@download.kopano.io/supported/archiver:/final/Debian_8.0/ ./
    deb https://serial:<>@download.kopano.io/supported/deskapp:/final/Debian_8.0/ ./
    

    Will change to 9.0 now :-) and update

    I will check your download folder for Debian 9
    thank you


  • Kopano

    Hi @scheini72 ,

    Debian Stretch is Debian 9. It seems you want to install Wheezy packages on stretch. Also: while Stretch is now supported for Core, WebApp is a different topic.



  • Hi all,
    put issue to solved.
    I missed to changed the sources.list file. Sorry and big thank you.

    Hint: It might be you have to uninstall php5-mapi via “dpkg --remove --force-depends php5-mapi”


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.