z-push auth against IMAP hosteurope



  • Hi,

    I am trying to auth against the IMAP server of hosteurope. But all the time I get following errors, what should I do to get the auth mechanism run? Port 143 is not working as it seems to force the backend to auth as plain. Usually port 143 is plain and STARTTLS. Port 993 is SSL/TLS

    28/10/2017 00:14:49 [21462] [WARN] [username] /usr/share/z-push/backend/imap/imap.php:108 imap_open(): Couldn't open stream {vwp1968.webpack.hosteurope.de:993/imap/notls/norsh} (2)
    28/10/2017 00:14:49 [21462] [ERROR] [username] BackendIMAP->Logon(): can't connect as user 'username' on '{vwp1968.webpack.hosteurope.de:993/imap/notls/norsh}': [CLOSED] IMAP connection broken (server response)
    28/10/2017 00:14:49 [21462] [FATAL] [username] Exception: (AuthenticationRequiredException) - Access denied. Username or password incorrect
    28/10/2017 00:14:49 [21462] [ERROR] [username] TopCollector could not initialise IPC provider '': No IPC provider available
    28/10/2017 00:14:49 [21462] [WARN] [username] Unknown:0 Unknown: [CLOSED] IMAP connection broken (server response) (errflg=2) (8)
    

    Thx for any help!

    Andy



  • Hi @raceface2nd ,
    what exactly is your problem?
    Is your kopano installed on an HE Virtual server or what’s your environment setup?
    If you give us a little more information we might be able to help you.
    Have you understood what z-push is for?
    best regards


  • Kopano

    @merlin2104 z-push can also be configured to connect to other servers than Kopano. In this case a general imap server.

    @raceface2nd said in z-push auth against IMAP hosteurope:

    28/10/2017 00:14:49 [21462] [WARN] [username] /usr/share/z-push/backend/imap/imap.php:108 imap_open(): Couldn’t open stream {vwp1968.webpack.hosteurope.de:993/imap/notls/norsh} (2)

    that sounds like the server name is either not correct or the connection fails due to the ssl settings.



  • Thank for the Info felix :-)
    @raceface2nd
    https://wiki.easycow.de/index.php/Z-Push
    maybe this helps you?
    Do you have a valid ssl certifiacte? If not the option
    define(‘IMAP_OPTIONS’, ‘/tls/novalidate-cert’);
    might help you.

    best regards



  • @fbartels : correct, it looks like the ssl settings are not working with the server.
    ssl-test shows that the server supports STARTTLS and TLS1.0 and TLS1.1.

    @Merlin2104 : Yes, I do know what z-push is for. In this case I do not use z-push with kopano. I want to connect zpush to an owncloud instance and use an imap server for authentication. The imap server has a valid certificate. It’s an IMAP server of the hoster hosteurope

    What I did not see, that I tried /notls option. So I changed to /tls. Now it looks like that z-push communicates with the imap server but something with the authentication goes wrong. I do know, that the error message says, that either the username or password or both might be incorrect. But I checked it dozens of times as well with a mail client and I am 100% sure, that the credentials I provided are correct.

    30/10/2017 21:39:27 [ 2278] [WARN] [user] /usr/share/z-push/backend/imap/imap.php:108 imap_open(): Couldn't open stream {vwp1968.webpack.hosteurope.de:993/imap} (2)
    30/10/2017 21:39:27 [ 2278] [ERROR] [user] BackendIMAP->Logon(): can't connect as user 'user' on '{vwp1968.webpack.hosteurope.de:993/imap}': [CLOSED] IMAP connection broken (server response)
    30/10/2017 21:39:27 [ 2278] [FATAL] [user] Exception: (AuthenticationRequiredException) - Access denied. Username or password incorrect
    30/10/2017 21:39:27 [ 2278] [ERROR] [user] TopCollector could not initialise IPC provider '': No IPC provider available
    

    How can I check more detailed what the problem might be?

    Andy


  • Kopano

    Hi Andy,

    is this the most recent log entry? The server Z-Push tries to connect to ("{vwp1968.webpack.hosteurope.de:993/imap}" ) lacks IMAP_OPTIONS. Have you set that in config.php of IMAP?

    Have you asked hosteurope which options you should use?

    Manfred



  • Dear Manfred,

    correct, that’s the most recent log entry. I tried arround with /tls and /ssl in the IMAP options but the result was still the same.

    The settings are done in the backend/IMAP/config.php file and are as follows

    define('IMAP_SERVER', 'vwp1968.webpack.hosteurope.de');
    define('IMAP_PORT', 993);
    define('IMAP_OPTIONS', '');
    

    Hosteurope supports Plain, SSL/TLS, STARTTLS on port 993. Unfortunately this is the only information I was able to get from hosteurope.

    Andy


  • Kopano

    Hi Andy,

    do you have some desktop client configured to sync with hosteurope, like Thunderbird? You could check which options you set there and then try to set the same in IMAP config.

    Manfred



  • @Manfred : Desktop Clients worked fine

    Maybe I had some typo error or I don’t know what went wrong in the past. I changed the IMAP_OPTIONS back to /ssl and it works.

    Emails are also synced to the client now, the only thing I am struggling with is carddav and caldav with owncloud. But I need to invent first, so I can mark this thread as solved.

    Andy


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.