Spooler don't send mails



  • After installation kopano, all emails hangs in “Postausgang”. The Log-File from the spooler shows:

    Fri Feb 24 13:31:22 2017: [debug  ] [24882] /usr/sbin/kopano-spooler kopano-spooler --send-message-entryid 00000000F83B1B5FC8F84509B0B0AE1E455E5161010000000500000012809FEAFA3F4708920602A41B004AB200000000 --send-username-enc 63687269737469616E --log-fd 5 --config /etc/kopano/spooler.cfg --host file:///var/run/kopano/server.sock --foreground localhost --port 25 --do-sentmail NULL
    Fri Feb 24 13:31:22 2017: [info   ] [24489] Spooler process started on pid 24882
    Fri Feb 24 13:31:22 2017: [debug  ] [24489] Received signal 17
    Fri Feb 24 13:31:22 2017: [debug  ] [24489] Cleaning 1 messages from queue
    Fri Feb 24 13:31:22 2017: [info   ] [24489] Processed message for user christian
    

    When I start the command without the last NULL, it works.

    Can anybody told me, whats wrong with my configuration?


  • Kopano

    Hello Christian,

    you log file does not really indicate that there has been an error sending the message, rather the transaction seems successful.

    Which version are you using? Did it work before for your? Did you already try to restart the spooler?



  • I use the version 8.3.0-849 from kopano core.

    When I restart the spooler, i get the following log messages on every restart:

    Fri Feb 24 14:54:02 2017: [info   ] [24492] Log process is done
    Fri Feb 24 14:54:02 2017: [info   ] [31514] Logger process started on pid 31517
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] StatsClient binding socket
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] StatsClient bound socket to /tmp/.42579d103624480c.sock
    Fri Feb 24 14:54:02 2017: [ notice] [31514] Starting kopano-spooler version 8,3,0,849 (849), pid 31514
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] Using SMTP server: localhost, port 25
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] Connection to storage server succeeded
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] Number of messages in the queue: 3
    Fri Feb 24 14:54:02 2017: [debug  ] [31519] /usr/sbin/kopano-spooler kopano-spooler --send-message-entryid 000000001CE5CA087AB64C33AA7CD81048C8EDE2010000000500000053D0E420686D46A19805BD625100CDB600000000 --send-username-enc 736F6E6A61 --log-fd 5 --config /etc/kopano/spooler.cfg --host file:///var/run/kopano/server.sock --foreground localhost --port 25 --do-sentmail NULL
    Fri Feb 24 14:54:02 2017: [info   ] [31514] Spooler process started on pid 31519
    Fri Feb 24 14:54:02 2017: [debug  ] [31520] /usr/sbin/kopano-spooler kopano-spooler --send-message-entryid 000000006DEE94BB6F6340F78BE534FB3DAA9CF201000000050000006931BF76D745458BA1B87A569E4AAE6600000000 --send-username-enc 6D6172676F74 --log-fd 5 --config /etc/kopano/spooler.cfg --host file:///var/run/kopano/server.sock --foreground localhost --port 25 --do-sentmail NULL
    Fri Feb 24 14:54:02 2017: [info   ] [31514] Spooler process started on pid 31520
    Fri Feb 24 14:54:02 2017: [debug  ] [31521] /usr/sbin/kopano-spooler kopano-spooler --send-message-entryid 000000006DEE94BB6F6340F78BE534FB3DAA9CF20100000005000000ABABD6BAD0AF4F6AB7DFB05AB5C60D4A00000000 --send-username-enc 6D6172676F74 --log-fd 5 --config /etc/kopano/spooler.cfg --host file:///var/run/kopano/server.sock --foreground localhost --port 25 --do-sentmail NULL
    Fri Feb 24 14:54:02 2017: [info   ] [31514] Spooler process started on pid 31521
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] Received signal 17
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] Cleaning 1 messages from queue
    Fri Feb 24 14:54:02 2017: [info   ] [31514] Processed message for user yyy
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] Received signal 17
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] Cleaning 1 messages from queue
    Fri Feb 24 14:54:02 2017: [info   ] [31514] Processed message for user xxx
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] Received signal 17
    Fri Feb 24 14:54:02 2017: [debug  ] [31514] Cleaning 1 messages from queue
    Fri Feb 24 14:54:02 2017: [info   ] [31514] Processed message for user xxx
    

  • Kopano

    that just looks like three successfully processed messages to me.



  • I found the problem. I had configured run_as_user und run_as_group to kopano. I change it to blank and now it works.


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.