Zarafa Send As / Delegates



  • I cannot get Zarafa Send As working on one particular server. It appears to me that there is a delegate permission overwriting the Send As function, but I cannot see where it is configured.

    I am trying to get richard to be able to send as accounts.

    I am using LDAP for authentication, and I have added the correct zarafaSendAsPrvilege to accounts.

    If I run:

    zarafa-admin --list-sendas accounts
    

    I get the following:

    Send-as list (1) for user user2:
    	Username 	Fullname	
    	-------------------------------
    	user1	       Richard LastName
    

    I can see the permission is set.

    However there appears to be a delegate permission overwriting this.

    If I log on to the mailbox of Richard I can manually type in accounts@domain.com in the From field, and this message will be sent from Richard LastName on behalf of Accounts.

    However, if I click on the drop-down arrow in the From field I get a message saying “No send as address configured”.

    I have looked in Webapp settings for both Richard and Accounts and there are no delegate permissions set in Settings. (although Richard does have full control of the Accounts mailbox so he can view/delete items, etc).

    Furthermore, if I run:

    zarafa-mailbox-permissions --list-permissions username
    

    for either user it does not list any delegate permissions.

    Store information username
    Delegate information:
    +------------------------------------+
    | Username | See private | Send copy |
    +------------------------------------+
    | -        | -           | -         |
    +------------------------------------+
    

    I have also tried:

    zarafa-mailbox-permissions --remove-all-permissions accounts
    

    but this does not seem to remove the “send on behalf of” permission.

    Finally, I have checked spooler.cfg and made sure the following is set:

    always_send_delegates = no
    

    Is there another global setting that might be overriding the Send As somewhere. If so can someone point me in the right directions to continue diagnosing this?

    Many thanks in advance.


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.