Migration from Zarafa to Kopano



  • Hey Guys,

    iam trying to install Kopano on a Debian 9 Server with OpenLDAP …

    Ive used for 3 years or more zarafa only with one mailbox on a debian 6 server. There are to many dependencies because i would not upgrade to debian 7/8/9.

    Is there anyway to import my old mails, files from zarafa to kopano?

    Ive used also openldap for authentication, mysql for the mails and the file setting for the attachment before.

    Best Regards

    Daniel



  • Hi BMWFan

    my best Way ;)

    https://forum.kopano.io/post/1137

    regards Sinux



  • According to the documentation, the database and attachments formats are unchanged between Zarafa and Kopano (depending on how old your version of Zarafa is). You should be able to do a fresh install of Kopano, then rsync the attachments across (don’t forget to reset the permissions, so they belong to the kopano user), export the Zarafa database using mysqldump and then import it into the Kopano database. Probably a good idea to stop the Kopano services while doing this and then start them again once you’ve finishing copying everything!


  • Kopano

    @bmwfan please be aware that due to https://jira.kopano.io/browse/KC-839 you should be running a 7.2.x before upgrading to Kopano.



  • @fbartels thank you of your Information.

    Thats the cause why i’am asking which options i have to migrate to kopano.

    Iam running on this 7.2.0-47017 zarafa version but i have read here Migration Quick Start-Guide-ZCP to Kopano Core that only Version 7.2.3 is a fork so for me totally compatible to kopano. In this case is a migrate like what kitserve describes anyhow functioning?

    Thanks in advance for your answers.


  • Kopano

    @bmwfan yes, of course. Your linked article (and also the steps decribed in the link) just say that the first Kopano version was pretty much identical with Zarafa 7.2.3. Not more, not less.



  • So for now, i have migrated my attachments, mysql and ldap from my old Debian 6 Server to the new Debian 9 Server. The Old MySQL Zarafa Database is imported and renamed to Kopano. (i hope thats all for the mysql part). The LDAP database is also imported. Kopano is installed.

    At the moment iam stucking at this point LDAP data transplantation to new schema
    kopano schema is imported.
    openldap is stopped.
    ive already created this file: zarafa2kopano.ldif
    ive already removed all files from folder /var/lib/ldap
    If i try to readd the “new” kopano ldap database, i get this error:
    alt text

    i hope someone can help me.

    Thanks in advance.



  • Now, i found the issue.
    In the file zarafa2kopano.ldif was the objectclass under my user still zarafa-user instead of kopano-user. Ive changed it and import it.

    Because of some alock package is unstable failures had i done this:

    cd /var/lib/ldap/
    chown openldap:openldap -R ./*
    

    then the Import was successfull.

    One Problem still exist, i cannot login in the kopano webapp.

    This is my Output if i make a ldapsearch:

    dn: cn=Horst Plero,cn=mailusers,dc=my-domain,dc=local
    givenName: Horst
    sn: Plero
    cn: Horst Plero
    uid: Horstler
    uidNumber: 1000
    gidNumber: 1000
    homeDirectory: /home/Horstler
    loginShell: /bin/sh
    objectClass: inetOrgPerson
    objectClass: posixAccount
    objectClass: top
    objectClass: kopano-user
    kopanoAccount: 1
    kopanoAdmin: 1
    mail: horst@my-domain.de
    mail: anything@my-domain.de
    mail: webmaster@my-domain.de
    mail: info@my-domain.de
    

    I know here Install Kopano Core on Debian with OpenLDAP
    are more entries as what i have in my output, but iam not sure if every entry is needed and how i can add it.

    The command kopano-admin -l give me this output:

    Unable to list users: "object" not found
    

    ive copied my ldap.cfg from my old zarafa Installation to the new kopano installation, i hope this is not the fault.

    Had anybody a idea why it is not functioning?



  • HI @BMWfan
    take a look here:
    https://forum.kopano.io/topic/442/ldap-migration-zarafa-kopano-not-working/8
    I had the same problem with the import :-)
    Looks like your ldap config is not correct - can you post it?
    rest regards



  • I think there are more dependencies. If i stop the Kopano-server and try to restart then i get this message:

    ● kopano-server.service - Kopano Core Storage Server
       Loaded: loaded (/lib/systemd/system/kopano-server.service; enabled; vendor pr
       Active: failed (Result: exit-code) since Sat 2017-11-11 18:11:30 CET; 1s ago
         Docs: man:kopano-server(8)
               man:kopano-server.cfg(5)
               man:kopano-admin(8)
      Process: 22072 ExecStart=/usr/sbin/kopano-server -F (code=exited, status=255)
     Main PID: 22072 (code=exited, status=255)```
    

    And the logs inlcudes this:

    Sat Nov 11 18:11:36 2017: [ notice] Starting kopano-server version 8.4.90 (pid 22107)
    Sat Nov 11 18:11:36 2017: [error  ] Coredumps will not be generated: kopano-server requires the fs.suid_dumpable sysctl to contain the value 2, not 0.
    Sat Nov 11 18:11:36 2017: [error  ] SQL [00000124] Failed: Unknown column 'micro' in 'field list', Query Size: 158, Query: "SELECT major, minor, micro, revision, databaserevision FROM versions ORDER BY major DESC, minor DESC, micro DESC, revision DESC, databaserevision DESC LIMIT 1"
    Sat Nov 11 18:11:36 2017: [error  ] KDatabase::DoSelect(): query failed: SELECT major, minor, micro, revision, databaserevision FROM versions ORDER BY major DESC, minor DESC, micro DESC, revision DESC, databaserevision DESC LIMIT 1: Unknown column 'micro' in 'field list'
    Sat Nov 11 18:11:36 2017: [error  ] Can't update the database:
    Sat Nov 11 18:11:36 2017: [ notice] Server shutdown complete.
    

    Is there anybody who knows how i can fix this, perhaps @fbartels ?



  • So, i ve solved it by myself.

    Ive installed a new Debian 7 Server with zarafa in version 7.2.0-48204, imported my mysql database , my ldap database and the zarafa server.cfg. Ive upgraded then to the newest version (7.2.6.10) and exported this database and imported it on my Primary new Server and it works. :-)

    The LDAP issue is also solved. Ive rechecked again all settings and found some faults which ive changed.

    Thanks for all :-)


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.