Z-Push no longer works after switch from Zarafa to Kopano and local install to packaged version



  • We recently migrated our mail from Zarafa 7.2.6 to the latest version of Kopano, and also Z-Push from a manual tarball install to the packaged version from the repos. Since then it no longer works. Client devices just get a ‘Connection to server failed’ error message. There is nothing in /var/log/z-push/z-push-error.log. I’m able to access the ActiveSync url using GET in a browser with no problems. Making a connection request from a device shows the following in /var/log/z-push/z-push.log:

    12/10/2017 19:20:57 [ 8638] [ INFO] [user] Options request
    12/10/2017 19:20:57 [ 8638] [ INFO] [user] cmd='' memory='1.67 MiB/2.00 MiB' time='0.05s' devType='' devId='' getUser='user' from='1.2.3.4' idle='0s' version='2.3.8+0-0' method='OPTIONS' httpcode='200'
    

    Nothing else appears. This looks related to https://forum.kopano.io/topic/601/z-push-connection-fails-on-imap-and-combined-backend/6, in that it fails without giving any useful debugging information, but there are some key differences. The system I’m referring to in this thread is Debian Jessie running Kopano as the backend and using PHP5 through FPM. The system in the other thread is Debian Stretch running an IMAP backend and using PHP7.0 through mod_php.

    Any help with debugging would be gratefully received because frankly, I’m at a loss.


  • Kopano

    Hi @kitserve ,

    Could you post the versions you are using?

    By default the packages expect that mod_php is used. Could you check if this would work?

    Was it an in place upgrade or install on a new machine? Did you remove all the files of the old Z-Push installation? Can you check if all the configuration files are resolving correctly?



  • Hi Felix,

    I was mistaken, Z-Push is running through mod_php after the upgrade. FPM is not in use.

    Debian Jessie 8.9
    Apache 2.4.10-10+deb8u11
    PHP 5.6.30+dfsg-0+deb8u1
    Kopano 8.4.90.448-0+80.1
    Z-Push 2.3.8+0-0

    This was an in place upgrade. I believe that all of the old Z-Push files were removed, certainly they were in a different directory (/usr/local/share/z-push as opposed to the new location of /usr/share/z-push). We left the state files in place.

    To make things more complicated, accounts on Android devices still seem to be working (or at least one of them). It only seems to be iOS devices that aren’t working. Here’s a snippet from the logs for an Android device.

    13/10/2017 11:23:54 [16834] [ INFO] [user] cmd='Sync' memory='3.11 MiB/3.50 MiB' time='0.26s' devType='Android' devId='androidXXXXXX' getUser='user' from='1.2.3.4' idle='0s' version='2.3.8+0-0' method='POST' httpcode='200'
    13/10/2017 11:23:54 [16834] [ INFO] [user] SyncCollections->CheckForChanges(): Waiting for store changes... (lifetime 1680 seconds)
    

    It looks as though iOS devices aren’t getting their devType and devId through to Z-Push, although I don’t know if that’s a cause or a symptom of the problem.



  • @fbartels said in Z-Push no longer works after switch from Zarafa to Kopano and local install to packaged version:

    Can you check if all the configuration files are resolving correctly?

    Oh, and what do you mean by this question?


  • Kopano

    @kitserve said in Z-Push no longer works after switch from Zarafa to Kopano and local install to packaged version:

    Oh, and what do you mean by this question?

    there is a config.php in /usr/share/z-push, but this is actually a symlink to /etc/z-push. Same accounts for the backend configuration.



  • hi @kitserve ,
    have you updated your IOS Deviced to the latest OS Version 11.03?
    Apple fixed in 11.02 and 11.03 a lot of “Mail Server problems” which occurred in IOS 11.

    Can you try the z-push with another client like windows mail oder outlook 2013++ ?
    For more infos, I recommend to set the Debug levelin /etc/z-push/ z-push.conf.php higher.

    Just for your info - I am running nearly the same environment.
    Debian 8, PHp 5.6, Apache 2.4., Z-Push 2.3.8 nad kopano 8.3.4.12-0+23.1. I don’t have any IOS deviced but Android and Outlook are working fine.
    Best regards



  • @fbartels: I edited the config files in /etc/z-push, and I can confirm that the symlinks for config.php and policies.ini in /usr/share/z-push are correctly set.

    @Merlin2104: We are an exclusively Linux shop, so I don’t have an easy way of testing with Window Mail or Outlook 2013/2016. I just tried increasing the log level to LOGLEVEL_WBXMLSTACK and recreating the account on an iPad mini 2, running the latest iOS 11.0.3. It failed with the error ‘Exchange Account - Unable to verify account information’. Log details are below:

    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] -------- Start
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] cmd='' devType='' devId='' getUser='user' from='1.2.3.4' version='2.3.8+0-0' method='OPTIONS'
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] Used timezone 'Europe/London'
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] BackendKopano using PHP-MAPI version: 8.4.90 - PHP version: 5.6.30-0+deb8u1
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] Request::ProcessHeaders() ASVersion: 14.0
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] KopanoBackend->Logon(): Trying to authenticate user 'user'..
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] KopanoBackend->openMessageStore('user'): Found 'DEFAULT' store: 'Resource id #17'
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] KopanoBackend->Logon(): User 'user' is authenticated
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] Store supports properties containing Unicode characters.
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] NoPostRequestException: Options request - code: 1 - file: /usr/share/z-push/index.php:66
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] ZPush::GetSupportedProtocolVersions(): 12.0,12.1,14.0
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] ZPush::GetSupportedCommands(): Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Ping,Notify,ItemOperations,Settings
    15/10/2017 11:26:50 [11603] [ INFO] [user] [] Options request
    15/10/2017 11:26:50 [11603] [ INFO] [user] [] cmd='' memory='1.67 MiB/2.00 MiB' time='0.06s' devType='' devId='' getUser='user' from='1.2.3.4' idle='0s' version='2.3.8+0-0' method='OPTIONS' httpcode='200'
    15/10/2017 11:26:50 [11603] [DEBUG] [user] [] -------- End
    

    Perhaps the NoPostRequest Exception is related?

    Thanks for your help so far.



  • Are you using a LetsEncrypt certificate?

    I have seen this happen on an iOS device when connecting to a z-push server configured with a LetsEncrypt certificate. It seems that Apple do not trust them by default.

    I just clicked on check details, and then accept (or whatever the option was called) and then it seemed to work OK



  • Thanks, good suggestion but we’re using a paid Comodo certificate, not Let’s Encrypt. The setup worked previously with Zarafa and the certificate hasn’t been changed.


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.