Z-Push Autodiscover on 2.3.7 not working as expected

Hello Community,

Z-Push is working as it should with my clients but the autodiscover feature does not.

If i follow this article in Z-Push Wiki and test my setup with my browser i only get the message that “Get is not supported” and there is no authetication pop up.

If i try autodiscover with Outlook 2016 it will fail, manual setup is working perfectly.

Here are my Logs and other details… Pastebin
The log entries are generated while i was setting up Outlook 2016.

Why is there no autentication pop up in my browser?
If i try it with Outlook 2016, the autentication process is logged.

Thanks in advance.

Hi Johann,

could you also post WBXML log of Outlook autodiscover?

Z-Push Autodiscover doesn’t support GET requests like the browser sends them, that’s why there’s no authentication pop-up.


25/08/2017 15:50:40 [22684] [WBXML] [unknown] ZPushAutodiscover->getIncomingXml() incoming XML data:
<?xml version="1.0" encoding="utf-8"?>
<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/requestschema/2006"><Request><EMailAddress>maxmustermann@musterfirma.com</EMailAddress><AcceptableResponseSchema>http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a</AcceptableResponseSchema></Request></Autodiscover>

I hope this helps.

Outlook says in German “Da hat etwas nicht geklappt”.

Hi Johann,

@juppin said in Z-Push Autodiscover on 2.3.7 not working as expected:

<Autodiscover xmlns=“http://schemas.microsoft.com/exchange/autodiscover/outlook/requestschema/2006”><Request><EMailAddress>maxmustermann@musterfirma.com</EMailAddress><AcceptableResponseSchema>http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a</AcceptableResponseSchema></Request></Autodiscover>

it’s because Outlook requests an AcceptableResponseSchema which Z-Push doesn’t support. There’s already a JIRA issue https://jira.z-hub.io/browse/ZP-1273 in which we will change the behaviour.


Thank you very much for your fast responses.

I think i can live with it for a while. :-)

As the new Outlook 2016 does not fall back to manual configuration use (and/or MobileSync requestschema)


or the old 32-bit mail control panel:


to configure your acconts

Hi @arnoutd ,

yes that is true. This is also something we recently integrated into the Kopano OL Extension, see https://jira.kopano.io/browse/KOE-134 for more details.

Did not experience that as I am an old Zarafa@Home uses that has some issues upgrading to the Kopano none release O/N builds as installs and I am not using the Outlook Connector beacause of that

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.