Shared calendars

When a normal user (no admin rights) give another user permissions to their calender as secretary they are unable to view the shared calendar in Webapp and Outlook with KOE. The permissions are set with Webapp.
When I open the calendar as admin I could view and mutate the calendar. What could be wrong?

WebApp:
3.3.1.628-26.1

Kopano Core:
8.3.2-15

KOE:
1.4.209

The calendar permissions has been configured in the option menu.

But when the user also configured the permissions by the options on the mailbox (right click on mailbox accountname --> properties --> permissions) and give the user folder visibility it was working as expected.

This behaviour is not user friendly!

Hi @leroyk2 ,

when talking about koe, then it is indeed needed to have “view folder permissions” on the root of the domain. that is also how sharing folders is documented, see https://kb.kopano.io/display/WIKI/Setting+up+the+Kopano+OL+Extension#SettinguptheKopanoOLExtension-Openingandclosingsharedfolders(suchascalendars)

at least when talking about the default calendar folder, this should work even without the “view folder privileges” in webapp, as WebApp has the possibility to open the default calendar in the store (which Z-Push is unable to know).

@fbartels

Strange, even for Webapp I should set the “view folder privileges”.

Hi @leroyk2 ,

You’re setting permissions via the delegations widget in WebApp’s settings. This only set permissions on a specific folder (e.g. calendar, inbox), which is fine is you only want to open this folder. Keep in mind this gives the user delegation permissions, which you might not want to do.

It seems you want to open the entire store, so permissions on the store it self are indeed necessary.

@marty said in Shared calendars:

It seems you want to open the entire store, so permissions on the store it self are indeed necessary.

I only want to share a calendar not a complete store. But I was unable to do this without the “view folder privileges”. Without this permission I could open the shared calendar but there were no items visible.

Hi @leroyk2 ,

its still not very clear to me what you are setting where. can you write up some detailed steps what you are setting where and how it you are trying to open the folder with the second user? As you describe it now I am not able to reproduce this issue locally.

user1

  • open webmail
  • go to options
  • go to delegates
  • choose add
  • select user2 and press ok
  • by calendar choose secretary and check the checkbox
  • press ok and apply

user2

  • open webmail
  • go to calendar
  • press open shared calendar +
  • press name
  • choose user1
  • press ok

Without “view folder privileges”. I am unable to see the calendar items.

Just followed your steps on a fresh testing machine

WebApp: 3.3.1.628-30.1
Kopano Core: 8.3.3-3

works fine for me.

@fbartels said in Shared calendars:

Just followed your steps on a fresh testing machine

WebApp: 3.3.1.628-30.1
Kopano Core: 8.3.3-3

works fine for me.

Strange! But thanks for your effort.

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.