Install Kopano Core community on Debian Stretch error -



  • Hai,

    I’m trying to install kopano core community version : 8.4.0~1103-0+10.1_amd64.deb
    I see packaging errors.

    dpkg -i *.deb
    Selecting previously unselected package gsoap.
    (Reading database ... 20188 files and directories currently installed.)
    Preparing to unpack gsoap_2.8.49-2.1_amd64.deb ...
    Unpacking gsoap (2.8.49-2.1) ...
    Selecting previously unselected package gsoap-dbg.
    Preparing to unpack gsoap-dbg_2.8.49-2.1_amd64.deb ...
    Unpacking gsoap-dbg (2.8.49-2.1) ...
    Selecting previously unselected package gsoap-dev.
    Preparing to unpack gsoap-dev_2.8.49-2.1_amd64.deb ...
    Unpacking gsoap-dev (2.8.49-2.1) ...
    dpkg: error processing archive gsoap-dev_2.8.49-2.1_amd64.deb (--install):
     trying to overwrite '/usr/bin/soapcpp2', which is also in package gsoap 2.8.49-2.1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Selecting previously unselected package gsoap-doc.
    Preparing to unpack gsoap-doc_2.8.49-2.1_all.deb ...
    Unpacking gsoap-doc (2.8.49-2.1) ...
    Selecting previously unselected package kopano-backup.
    Preparing to unpack kopano-backup_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-backup (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-bash-completion.
    Preparing to unpack kopano-bash-completion_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-bash-completion (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-client.
    Preparing to unpack kopano-client_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-client (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-common.
    Preparing to unpack kopano-common_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-common (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-contacts.
    Preparing to unpack kopano-contacts_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-contacts (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-dagent.
    Preparing to unpack kopano-dagent_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-dagent (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-dbg.
    Preparing to unpack kopano-dbg_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-dbg (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-dev.
    Preparing to unpack kopano-dev_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-dev (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-gateway.
    Preparing to unpack kopano-gateway_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-gateway (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-ical.
    Preparing to unpack kopano-ical_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-ical (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-lang.
    Preparing to unpack kopano-lang_8.4.0~1103-0+10.1_all.deb ...
    Unpacking kopano-lang (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-migration-imap.
    Preparing to unpack kopano-migration-imap_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-migration-imap (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-migration-pst.
    Preparing to unpack kopano-migration-pst_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-migration-pst (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-monitor.
    Preparing to unpack kopano-monitor_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-monitor (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-presence.
    Preparing to unpack kopano-presence_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-presence (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-search.
    Preparing to unpack kopano-search_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-search (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-server.
    Preparing to unpack kopano-server_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-server (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-server-packages.
    Preparing to unpack kopano-server-packages_8.4.0~1103-0+10.1_all.deb ...
    Unpacking kopano-server-packages (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-spooler.
    Preparing to unpack kopano-spooler_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-spooler (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package kopano-utils.
    Preparing to unpack kopano-utils_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking kopano-utils (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libgsoap-dbg.
    Preparing to unpack libgsoap-dbg_2.8.49-2.1_amd64.deb ...
    Unpacking libgsoap-dbg (2.8.49-2.1) ...
    Selecting previously unselected package libgsoap-kopano-2-8-49.
    Preparing to unpack libgsoap-kopano-2-8-49_2.8.49-2.1_amd64.deb ...
    Unpacking libgsoap-kopano-2-8-49 (2.8.49-2.1) ...
    Selecting previously unselected package libjansson4:amd64.
    Preparing to unpack libjansson4_2.7-1_amd64.deb ...
    Unpacking libjansson4:amd64 (2.7-1) ...
    Selecting previously unselected package libjansson-dbg:amd64.
    Preparing to unpack libjansson-dbg_2.7-1_amd64.deb ...
    Unpacking libjansson-dbg:amd64 (2.7-1) ...
    Selecting previously unselected package libjansson-dev:amd64.
    Preparing to unpack libjansson-dev_2.7-1_amd64.deb ...
    Unpacking libjansson-dev:amd64 (2.7-1) ...
    Selecting previously unselected package libjansson-doc.
    Preparing to unpack libjansson-doc_2.7-1_all.deb ...
    Unpacking libjansson-doc (2.7-1) ...
    Selecting previously unselected package libkcarchiver0.
    Preparing to unpack libkcarchiver0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcarchiver0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcarchivercore0.
    Preparing to unpack libkcarchivercore0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcarchivercore0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcfreebusy0.
    Preparing to unpack libkcfreebusy0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcfreebusy0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkchl0.
    Preparing to unpack libkchl0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkchl0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcicalmapi0.
    Preparing to unpack libkcicalmapi0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcicalmapi0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcinetmapi0.
    Preparing to unpack libkcinetmapi0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcinetmapi0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcmapi0.
    Preparing to unpack libkcmapi0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcmapi0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcpyconv0.
    Preparing to unpack libkcpyconv0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcpyconv0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcpydirector0.
    Preparing to unpack libkcpydirector0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcpydirector0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcserver0.
    Preparing to unpack libkcserver0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcserver0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcsoap0.
    Preparing to unpack libkcsoap0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcsoap0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcssl0.
    Preparing to unpack libkcssl0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcssl0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcsync0.
    Preparing to unpack libkcsync0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcsync0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libkcutil0.
    Preparing to unpack libkcutil0_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libkcutil0 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libmapi1.
    Preparing to unpack libmapi1_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking libmapi1 (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package libs3-3.
    Preparing to unpack libs3-3_3.0~git226-5.7_amd64.deb ...
    Unpacking libs3-3 (3.0~git226-5.7) ...
    Selecting previously unselected package libs3-3-dbgsym.
    Preparing to unpack libs3-3-dbgsym_3.0~git226-5.7_amd64.deb ...
    Unpacking libs3-3-dbgsym (3.0~git226-5.7) ...
    Selecting previously unselected package libs3-dev.
    Preparing to unpack libs3-dev_3.0~git226-5.7_amd64.deb ...
    Unpacking libs3-dev (3.0~git226-5.7) ...
    Selecting previously unselected package libtidy5.
    Preparing to unpack libtidy5_5.1.9-1.7_amd64.deb ...
    Unpacking libtidy5 (5.1.9-1.7) ...
    Selecting previously unselected package libtidy5-dbgsym.
    Preparing to unpack libtidy5-dbgsym_5.1.9-1.7_amd64.deb ...
    Unpacking libtidy5-dbgsym (5.1.9-1.7) ...
    Selecting previously unselected package libvmime-dev.
    Preparing to unpack libvmime-dev_0.9.2-12.1_amd64.deb ...
    Unpacking libvmime-dev (0.9.2-12.1) ...
    Selecting previously unselected package libvmime-kopano1.
    Preparing to unpack libvmime-kopano1_0.9.2-12.1_amd64.deb ...
    Unpacking libvmime-kopano1 (0.9.2-12.1) ...
    Selecting previously unselected package libvmime-kopano1-dbgsym.
    Preparing to unpack libvmime-kopano1-dbgsym_0.9.2-12.1_amd64.deb ...
    Unpacking libvmime-kopano1-dbgsym (0.9.2-12.1) ...
    Selecting previously unselected package php7-mapi.
    Preparing to unpack php7-mapi_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking php7-mapi (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package python-kopano.
    Preparing to unpack python-kopano_8.4.0~1103-0+10.1_all.deb ...
    Unpacking python-kopano (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package python-mapi.
    Preparing to unpack python-mapi_8.4.0~1103-0+10.1_amd64.deb ...
    Unpacking python-mapi (8.4.0~1103-0+10.1) ...
    Selecting previously unselected package tidy-html5.
    Preparing to unpack tidy-html5_5.1.9-1.7_amd64.deb ...
    Unpacking tidy-html5 (5.1.9-1.7) ...
    Selecting previously unselected package tidy-html5-dbgsym.
    Preparing to unpack tidy-html5-dbgsym_5.1.9-1.7_amd64.deb ...
    Unpacking tidy-html5-dbgsym (5.1.9-1.7) ...
    Selecting previously unselected package tidy-html5-dev.
    Preparing to unpack tidy-html5-dev_5.1.9-1.7_amd64.deb ...
    Unpacking tidy-html5-dev (5.1.9-1.7) ...
    dpkg: dependency problems prevent configuration of gsoap:
     gsoap depends on gsoap-kopano-dev; however:
      Package gsoap-kopano-dev is not installed.
    
    dpkg: error processing package gsoap (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gsoap-dbg:
     gsoap-dbg depends on gsoap-kopano-dev (= 2.8.49-2.1); however:
      Package gsoap-kopano-dev is not installed.
    
    dpkg: error processing package gsoap-dbg (--install):
     dependency problems - leaving unconfigured
    Setting up gsoap-doc (2.8.49-2.1) ...
    dpkg: dependency problems prevent configuration of kopano-bash-completion:
     kopano-bash-completion depends on bash-completion; however:
      Package bash-completion is not installed.
    
    dpkg: error processing package kopano-bash-completion (--install):
     dependency problems - leaving unconfigured
    Setting up kopano-common (8.4.0~1103-0+10.1) ...
    dpkg: dependency problems prevent configuration of kopano-dagent:
     kopano-dagent depends on libmariadb2 (>= 2.0.0); however:
      Package libmariadb2 is not installed.
     kopano-dagent depends on php-cli | php5-cli | php7.0-cli; however:
      Package php-cli is not installed.
      Package php5-cli is not installed.
      Package php7.0-cli is not installed.
    
    dpkg: error processing package kopano-dagent (--install):
     dependency problems - leaving unconfigured
    Setting up kopano-dbg (8.4.0~1103-0+10.1) ...
    dpkg: dependency problems prevent configuration of kopano-dev:
     kopano-dev depends on libicu-dev; however:
      Package libicu-dev is not installed.
    
    dpkg: error processing package kopano-dev (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-ical:
     kopano-ical depends on libical2 (>= 2.0.0); however:
      Package libical2 is not installed.
    
    dpkg: error processing package kopano-ical (--install):
     dependency problems - leaving unconfigured
    Setting up kopano-lang (8.4.0~1103-0+10.1) ...
    dpkg: dependency problems prevent configuration of kopano-migration-imap:
     kopano-migration-imap depends on libdigest-hmac-perl; however:
      Package libdigest-hmac-perl is not installed.
     kopano-migration-imap depends on libfile-copy-recursive-perl; however:
      Package libfile-copy-recursive-perl is not installed.
     kopano-migration-imap depends on libunicode-string-perl; however:
      Package libunicode-string-perl is not installed.
     kopano-migration-imap depends on libreadonly-perl; however:
      Package libreadonly-perl is not installed.
     kopano-migration-imap depends on libio-tee-perl; however:
      Package libio-tee-perl is not installed.
     kopano-migration-imap depends on libmail-imapclient-perl; however:
      Package libmail-imapclient-perl is not installed.
    
    dpkg: error processing package kopano-migration-imap (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-presence:
     kopano-presence depends on python-flask; however:
      Package python-flask is not installed.
     kopano-presence depends on python-sleekxmpp; however:
      Package python-sleekxmpp is not installed.
    
    dpkg: error processing package kopano-presence (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-search:
     kopano-search depends on python-xapian; however:
      Package python-xapian is not installed.
     kopano-search depends on gawk; however:
      Package gawk is not installed.
     kopano-search depends on w3m; however:
      Package w3m is not installed.
     kopano-search depends on xsltproc; however:
      Package xsltproc is not installed.
     kopano-search depends on poppler-utils; however:
      Package poppler-utils is not installed.
     kopano-search depends on unzip; however:
      Package unzip is not installed.
     kopano-search depends on catdoc; however:
      Package catdoc is not installed.
     kopano-search depends on xapian-tools; however:
      Package xapian-tools is not installed.
    
    dpkg: error processing package kopano-search (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-server:
     kopano-server depends on libmariadb2 (>= 2.0.0); however:
      Package libmariadb2 is not installed.
     kopano-server depends on libtcmalloc-minimal4; however:
      Package libtcmalloc-minimal4 is not installed.
    
    dpkg: error processing package kopano-server (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-server-packages:
     kopano-server-packages depends on kopano-dagent (= 8.4.0~1103-0+10.1); however:
      Package kopano-dagent is not configured yet.
     kopano-server-packages depends on kopano-ical (= 8.4.0~1103-0+10.1); however:
      Package kopano-ical is not configured yet.
     kopano-server-packages depends on kopano-presence (= 8.4.0~1103-0+10.1); however:
      Package kopano-presence is not configured yet.
     kopano-server-packages depends on kopano-search (= 8.4.0~1103-0+10.1); however:
      Package kopano-search is not configured yet.
     kopano-server-packages depends on kopano-server (= 8.4.0~1103-0+10.1); however:
      Package kopano-server is not configured yet.
    
    dpkg: error processing package kopano-server-packages (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-spooler:
     kopano-spooler depends on libmariadb2 (>= 2.0.0); however:
      Package libmariadb2 is not installed.
    
    dpkg: error processing package kopano-spooler (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-utils:
     kopano-utils depends on libcurl3 (>= 7.16.2); however:
      Package libcurl3 is not installed.
    
    dpkg: error processing package kopano-utils (--install):
     dependency problems - leaving unconfigured
    Setting up libgsoap-kopano-2-8-49 (2.8.49-2.1) ...
    Setting up libjansson4:amd64 (2.7-1) ...
    Setting up libjansson-dbg:amd64 (2.7-1) ...
    Setting up libjansson-dev:amd64 (2.7-1) ...
    dpkg: dependency problems prevent configuration of libjansson-doc:
     libjansson-doc depends on libjs-backbone; however:
      Package libjs-backbone is not installed.
     libjansson-doc depends on libjs-jquery; however:
      Package libjs-jquery is not installed.
     libjansson-doc depends on libjs-underscore; however:
      Package libjs-underscore is not installed.
     libjansson-doc depends on libjs-sphinxdoc (>= 1.0); however:
      Package libjs-sphinxdoc is not installed.
    
    dpkg: error processing package libjansson-doc (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcarchivercore0:
     libkcarchivercore0 depends on libmariadb2 (>= 2.0.0); however:
      Package libmariadb2 is not installed.
    
    dpkg: error processing package libkcarchivercore0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcicalmapi0:
     libkcicalmapi0 depends on libical2 (>= 2.0.0); however:
      Package libical2 is not installed.
    
    dpkg: error processing package libkcicalmapi0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcinetmapi0:
     libkcinetmapi0 depends on libkcicalmapi0; however:
      Package libkcicalmapi0 is not configured yet.
    
    dpkg: error processing package libkcinetmapi0 (--install):
     dependency problems - leaving unconfigured
    Setting up libkcpydirector0 (8.4.0~1103-0+10.1) ...
    dpkg: dependency problems prevent configuration of libkcserver0:
     libkcserver0 depends on libmariadb2 (>= 2.0.0); however:
      Package libmariadb2 is not installed.
    
    dpkg: error processing package libkcserver0 (--install):
     dependency problems - leaving unconfigured
    Setting up libkcutil0 (8.4.0~1103-0+10.1) ...
    dpkg: dependency problems prevent configuration of libs3-3:
     libs3-3 depends on libcurl3-gnutls (>= 7.16.2); however:
      Package libcurl3-gnutls is not installed.
    
    dpkg: error processing package libs3-3 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libs3-3-dbgsym:
     libs3-3-dbgsym depends on libs3-3 (= 3.0~git226-5.7); however:
      Package libs3-3 is not configured yet.
    
    dpkg: error processing package libs3-3-dbgsym (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libs3-dev:
     libs3-dev depends on libs3-3 (= 3.0~git226-5.7); however:
      Package libs3-3 is not configured yet.
    
    dpkg: error processing package libs3-dev (--install):
     dependency problems - leaving unconfigured
    Setting up libtidy5 (5.1.9-1.7) ...
    Setting up libtidy5-dbgsym (5.1.9-1.7) ...
    Setting up libvmime-kopano1 (0.9.2-12.1) ...
    Setting up libvmime-kopano1-dbgsym (0.9.2-12.1) ...
    dpkg: dependency problems prevent configuration of php7-mapi:
     php7-mapi depends on libkcicalmapi0; however:
      Package libkcicalmapi0 is not configured yet.
     php7-mapi depends on libkcinetmapi0; however:
      Package libkcinetmapi0 is not configured yet.
     php7-mapi depends on phpapi-20151012; however:
      Package phpapi-20151012 is not installed.
    
    dpkg: error processing package php7-mapi (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-kopano:
     python-kopano depends on python-dateutil; however:
      Package python-dateutil is not installed.
    
    dpkg: error processing package python-kopano (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-mapi:
     python-mapi depends on libical2 (>= 2.0.0); however:
      Package libical2 is not installed.
     python-mapi depends on libkcicalmapi0; however:
      Package libkcicalmapi0 is not configured yet.
     python-mapi depends on libkcinetmapi0; however:
      Package libkcinetmapi0 is not configured yet.
    
    dpkg: error processing package python-mapi (--install):
     dependency problems - leaving unconfigured
    Setting up tidy-html5 (5.1.9-1.7) ...
    Setting up tidy-html5-dbgsym (5.1.9-1.7) ...
    Setting up tidy-html5-dev (5.1.9-1.7) ...
    dpkg: dependency problems prevent configuration of kopano-backup:
     kopano-backup depends on python-kopano; however:
      Package python-kopano is not configured yet.
    
    dpkg: error processing package kopano-backup (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-gateway:
     kopano-gateway depends on libkcinetmapi0; however:
      Package libkcinetmapi0 is not configured yet.
    
    dpkg: error processing package kopano-gateway (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-migration-pst:
     kopano-migration-pst depends on python-kopano; however:
      Package python-kopano is not configured yet.
    
    dpkg: error processing package kopano-migration-pst (--install):
     dependency problems - leaving unconfigured
    Setting up libgsoap-dbg (2.8.49-2.1) ...
    Setting up libkcmapi0 (8.4.0~1103-0+10.1) ...
    Setting up libkcsoap0 (8.4.0~1103-0+10.1) ...
    Setting up libkcssl0 (8.4.0~1103-0+10.1) ...
    Setting up libvmime-dev (0.9.2-12.1) ...
    Setting up libkcfreebusy0 (8.4.0~1103-0+10.1) ...
    Setting up libkcsync0 (8.4.0~1103-0+10.1) ...
    Setting up kopano-client (8.4.0~1103-0+10.1) ...
    Setting up libmapi1 (8.4.0~1103-0+10.1) ...
    Setting up kopano-contacts (8.4.0~1103-0+10.1) ...
    Setting up kopano-monitor (8.4.0~1103-0+10.1) ...
    Setting up libkcarchiver0 (8.4.0~1103-0+10.1) ...
    Setting up libkchl0 (8.4.0~1103-0+10.1) ...
    Setting up libkcpyconv0 (8.4.0~1103-0+10.1) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Processing triggers for systemd (232-25+deb9u1) ...
    Processing triggers for libc-bin (2.24-11+deb9u1) ...
    Errors were encountered while processing:
     gsoap-dev_2.8.49-2.1_amd64.deb
     gsoap
     gsoap-dbg
     kopano-bash-completion
     kopano-dagent
     kopano-dev
     kopano-ical
     kopano-migration-imap
     kopano-presence
     kopano-search
     kopano-server
     kopano-server-packages
     kopano-spooler
     kopano-utils
     libjansson-doc
     libkcarchivercore0
     libkcicalmapi0
     libkcinetmapi0
     libkcserver0
     libs3-3
     libs3-3-dbgsym
     libs3-dev
     php7-mapi
     python-kopano
     python-mapi
     kopano-backup
     kopano-gateway
     kopano-migration-pst
    


  • apt-get install -f
    

    should pull in the required packages



  • Hai Galen,

    Sorry but that is not the problem. i have all packages also in my personal repo.
    that failed so i pulled a tar.gz and tried one manualy.
    Now, this is a packaging error, not installation error.

    I mean this part.

    dpkg: error processing archive gsoap-dev_2.8.49-2.1_amd64.deb (--install):
     trying to overwrite '/usr/bin/soapcpp2', which is also in package gsoap 2.8.49-2.1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    

    The same file in 2 packages is not debian policy.



  • Ah, i see.

    I have 8.4.0~1074-4 in my local repo and they install without the error you see.

    I can mail them if you want to compare?

    G


  • Kopano

    @thctlo instead of installing every package provided by the gzip, i would recommend to install kopano-server-packages and its dependencies only. that should already give you the most used packages.



  • Guys,

    Sorry its confusing what i saying here…
    i’ll try again.

    I’ve installed kopano on a debian stretch and i saw the following packaging error.

    Selecting previously unselected package gsoap-dev.
    Preparing to unpack gsoap-dev_2.8.49-2.1_amd64.deb ...
    Unpacking gsoap-dev (2.8.49-2.1) ...
    dpkg: error processing archive gsoap-dev_2.8.49-2.1_amd64.deb (--install):
     trying to overwrite '/usr/bin/soapcpp2', which is also in package gsoap 2.8.49-2.1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)```
    

    and again, i know how to install kopano, thats not the problem i am reporting.
    its is a simple packaging bug in the debian packages im reporting.

    thats it.

    @ Galen, thanks but not needed.
    @ Felix, thanks that good info, but why is that not in :
    https://documentation.kopano.io/kopanocore_administrator_manual/installing.html#deb-based-distributions

    Sorry if it looks like im bashing here, but im not, i just did a test install on a debian stretch, by following the documentation and i noticed that its wrong.

    and thats what im reporting.

    Greetz,

    Louis


  • Kopano

    @thctlo said in Install Kopano Core community on Debian Stretch error -:

    @ Felix, thanks that good info, but why is that not in :

    it is:

    After configuring the desired Kopano Core repository Kopano can simply be installed through the meta package “kopano-server-packages”.

    Anyways, I have created https://jira.kopano.io/browse/KC-760 to fix the gsoap-dev package.



  • it does not look like that if a “newbe” is installing for the first time.

    i simply suggest you change or put that message where is understandable for newbies…

    3.2.2.2. DEB based distributions
    On DEB based distributions (most commonly Debian and Ubuntu) use:
    dpkg -i <package files you want to install>

    why not.

    3.2.2.2. DEB based distributions
    On DEB based distributions (most commonly Debian and Ubuntu) use:
    dpkg -i <package files you want to install> or
    dpkg -i kopano-server-packages
    Which installs the complete KopanoCore stack on a server.

    just my thoughts.


  • Kopano

    @thctlo this is because you cannot resolve dependencies that are not part of the debian repository this way. doing a dpkg -i kopano-server-packages*.deb && apt install -f will bring you nowhere.



  • ah, your correct, you should add the part with the “file repo” … i took you script and adjusted it a bit. (see below)
    The “why” i changed it, now its very easy to adapt this to a webserver repo and when you use different archtectures, you cant mix the amd and i386 files in one repo. If you want that you need a more advanced setup.

    to change this to webserver repo: (example)
    deb [trusted=yes] file:/home/kopano/deb/core amd64/

    deb [trusted=yes] http:// hostname.or.IP/ amd64/
    This is my webserver document root: /home/kopano/deb/core

    #!/bin/bash
    
    ARCH=$(arch)
    if [ ${arch} = x86_64 ]
    then
        ARCH=amd64
        [ ! -d amd64 ]
        mkdir amd64
        mv *.deb amd64
    elif [ ${arch} = i386 ]||[ ${arch} = i686 ]
    then
        ARCH=i386
        [ ! -d i386 ]
        mkdir i386
        mv *.deb i386
    fi
    
    read -p "Create a local apt repo from the current dir? (y/n) " RESP
    if [ "$RESP" = "y" ]; then
            apt-ftparchive packages $ARCH/ | gzip -9c > $ARCH/Packages.gz
    fi
    
    echo "To use this repo we will added the following file: "
    echo " /etc/apt/sources.list.d/kopano-community.list"
    echo "Which containing the line: "
    echo "deb [trusted=yes] file:$(pwd) $ARCH/"
    echo "deb [trusted=yes] file:$(pwd) $ARCH/" > /etc/apt/sources.list.d/kopano-community.list
    echo
    echo "you can call apt-get the following way now:"
    echo "apt-get install kopano-server-packages"
    

    Greetz,

    Louis


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.