Kopano-Server Memory usage

Hello Forum,

since i installed KC 8.3.0-1024 i’ve got huge amounts of data stored in RAM (about 9GB from 16GB)
after some hours (in my case 16h interval the server (centos) starts to swap all the data even with vm.swappingness=1.
Server-Data:

CentOS Linux release 7.3.1611 (Core)
16GB RAM
4 Cores (1 Socket / 4 Cores per socket)
VM created on vmware ESXi 5.5 (VM hardware-version 10)

Kopano-Server config:

[...]
# Database engine (mysql)
database_engine         = mysql
owner_auto_full_access = true
session_timeout         = 300
audit_log_enabled       = no

mysql_host              = localhost
mysql_port              = 3306
attachment_storage      = files

# THREAD SETTINGS

# Number of server threads
# default: 8
threads                 =       8

# Watchdog frequency. The number of watchdog checks per second.
# default: 1
watchdog_frequency      =       1

# Watchdog max age. The maximum age in ms of a task before a
# new thread is started.
# default: 500
watchdog_max_age        =       500

# Maximum SOAP keep_alive value
# default: 100
server_max_keep_alive_requests  =       100

# SOAP recv timeout value (time between requests)
# default: 5
server_recv_timeout     =       5

# SOAP read timeout value (time during requests)
# default: 60
server_read_timeout     =       60

# SOAP send timeout value
# default: 60
server_send_timeout     =       60

# CACHE SETTINGS
#
# To see the live cache usage, use 'kopano-stats --system'.

# Size in bytes of the 'cell' cache (should be set as high as you can afford to set it)
cache_cell_size                         = 1024M

# Size in bytes of the 'object' cache
#cache_object_size = 13M

# Size in bytes of the 'indexed object' cache
#cache_indexedobject_size = 67M

# Size in bytes of the userquota details
cache_quota_size                        = 1M

# Lifetime for userquota details
cache_quota_lifetime            = 1

# Size in bytes of the acl cache
cache_acl_size                          = 1M

# Size in bytes of the store id/guid cache
cache_store_size                        = 1M

# Size in bytes of the 'user id' cache (this is allocated twice)
cache_user_size                         = 1M

# Size in bytes of the 'user details' cache
cache_userdetails_size          = 25M

# Lifetime for user details
cache_userdetails_lifetime      = 0

# Size in bytes of the server details (multiserver setups only)
cache_server_size                       = 1M

# Lifetime for server details (multiserver setups only)
cache_server_lifetime   = 30


# MISC SETTING 
thread_stacksize = 512
enable_hosted_kopano = false
enable_distributed_kopano = false

MariaDB config:

[mysqld]
socket=/var/lib/mysql/mysql.sock
default-storage-engine=InnoDB
symbolic-links=0

datadir=/export/data/mail/db
innodb_buffer_pool_size = 4096M
innodb_log_file_size = 512M
innodb_log_buffer_size = 16M
max_allowed_packet = 32M
max_connections = 300
innodb_file_per_table=1
long_query_time = 5
query_cache_size = 64M
thread_cache_size = 80
table_cache = 200
join_buffer_size = 256K
innodb_buffer_pool_instances = 2

I’ve found an error-enty same time, the swap starts riseing:

Thu Jul  6 09:58:36 2017: [error  ] SQL [00000015] result failed: Deadlock found when trying to get lock; try restarting transaction, Query: "SELECT * FROM properties WHERE hierarchyid IN(67480) LOCK IN SHARE MODE"
SELECT hierarchyid FROM properties WHERE hierarchyid IN(67480):
 +-------------+
| hierarchyid |
+-------------+
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
|       67480 |
+-------------+

if i use “*” instead of hierarchyid i will get results that cant be displayed via putty.

0_1499335901175_0921d5f5-727a-4cbe-ada1-b71c95fa2559-grafik.png
Some issues known?

Coffee_is_life

@Coffee_is_life without looking further into your post, please update to 8.3.1 or 8.3.2 (currently available as RC, will be released as final this week) and try again. An issue which could lead to a memory leak was fixed in 8.3.1.

hello @fbartels,

i’ve upgraded some time ago, cam back from holiday and the server runs smoothly - was this mem leak

thanks for the help -closed-

Coffee_is_life