Problems configuring send-as



  • Hi Guys,

    I have Kopano-Core 8.4.0-984 and also have a send as issue.

    I use OpenLDAP, and have created a group with the following using phpLDAPadmin:
    objectClass: kopano-group
    kopanoSendAsPrivilege: User1
    memberUid: User1
    kopanoAccount: 1
    mail: groupname@domain.com

    I log into the WebApp and update the emails “From” address to be the group’s mail address by selecting it from the GAL then add a subject and some text. I set the To address to be a local user in the system and hit send.

    I get the following return email:

    Unfortunately, I was unable to deliver your mail.
    The error given was:
    
    The user or group you try to send as could not be found.
    
    You may need to contact your e-mail administrator to solve this problem.
    

    The following is logged in spooler.log

    [info   ] [14893] Unable to open representing user in addressbook: interface not supported (80004002)
    [error  ] [14893] CheckSendAs(): OpenEntry failed(1) 80004002
    [error  ] [14893] User "<unknown>" is not allowed to send as user or group "<unknown>". You may enable all outgoing addresses by enabling the always_send_delegates option.
    

    If i try to send as a user with the same settings, it also fails.

    Not sure whats going on here… has anyone seen this ?



  • After some more research, i found the following:

    “kopano-admin -l” and i get a list with only the users that are kopano-user type

    “kopano-admin -L” and i get a list of all the groups with kopano-group type

    “kopano-admin --details Group1 --type group” and i get a list of all members of the group

    “kopano-admin --list-sendas Group1” and there is nothing listed

    “kopano-admin --list-sendas User1” and there is nothing listed

    Error in server.log

    [warning] Unable to retrieve parents for relation groupmember: uid attribute not found.
    

    So looks like the info is not syncing from OpenLDAP for the users listed on the group object under “kopanoSendAsPrivilege”

    when looking at the group in phpLDAPadmin, the field “kopanoSendAsPrivilege” is set with the CN of the users that should be able to “Send As” the group email address, however Kopano sync is not reading this field.

    Any ideas why not ?



  • Ok so something wasnt sync-ing properly, but now i get the correct users listed when running:

    “kopano-admin --details Group1 --type group” I get a list of all members of the group
    “kopano-admin --list-sendas Group1 --type group” I get a list of all members of the group

    Yet when trying to send as, the message still fails as my first post.


  • Kopano

    Hi @oracle_sod ,

    I’ve moved your posts into a thread if their own. Are the error message still the same as in the first post? or do you get different error messages?



  • Hi @fbartels ,

    Thanks for that.

    Yep, the errors are still the same for the spooler.log when trying to send a message



  • I have tried putting the CN the UID and the Mail address in the kopanoSendAsPrivilege…

    All give the same issue and the same log entries…

    Anyone seen this before ?


  • Kopano

    Hi @oracle_sod ,

    i did not yet find the time to reproduce this issue myself, but if you have a subscription you could open up a support case and have our support reproduce the issue.

    as for

    I have tried putting the CN the UID and the Mail address in the kopanoSendAsPrivilege…

    what is the correct value here depends on your configuration:

    # Optional
    # The attribute which indicates which users are allowed
    # to send on behalf of the selected user
    ldap_sendas_attribute = kopanoSendAsPrivilege
    
    # Optional, default = text
    # Active directory: dn
    # LDAP: text
    ldap_sendas_attribute_type = text
    
    # The attribute of the user and group which is listed in
    # the ldap_sendas_attribute
    # Empty default, using ldap_user_unique_attribute
    ldap_sendas_relation_attribute =      
    


  • Hi @fbartels ,

    Thanks for the info. I have confirmed that the ldap settings are as follows:

    ldap_sendas_attribute = kopanoSendAsPrivilege
    ldap_sendas_attribute_type = text
    ldap_sendas_relation_attribute = uid
    

    and that when set correctly i can run “kopano-admin --list-sendas Group1 --type group” and see all the intended users in the list.

    I have tried with the variables set and unset (also tried with the relation attribute as uidNumber after i updated the LDAP records to be the number) still the same results, i see the users in the send as list command but the mail fails to send with the log above.

    Unfortunately I don’t have a subscription so I assume there is no way to log a support ticket.

    I also tried updating to the latest build from last night (didnt make a difference)


  • Kopano

    @oracle_sod ok, no problem. I have anyways put it on my list for the 8.4.0 beta1 testing.



  • Thanks for that @fbartels , let me know how you go… Happy to provide any further detail you require.


  • Kopano

    Hi @oracle_sod ,

    I finally got around testing this and while this works with the release packages (tested with 8.3.2) it sadly fails with the packages from master. I created https://jira.kopano.io/browse/KC-763 to have this fixed.


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.