Certificates for S/MIME

Hi,

Indeed I am using the master version of S/MIME.

It’s ok, I can wait for it to be fixed in Master.

But in essence what you are saying, if I understand correctly, is that the Comodo certificates are OK?

thanks for confirming.

I cannot unfortunately see the JIRA but I will try again perhaps next week to download the latest version.

Hi,

Unfortunately I cannot see the S/MIME JIRA, it appears to be locked.

Is there any way to know when it will be fixed in the main branch?

Thanks.

I can now thanks.

@marty

Question for:
https://jira.kopano.io/browse/KSP-128

The last comment on that JIRA mentions that the problem is fixed on the PHP sourcecode.

But does it mean that the Kopano issue will be fixed before though?

Our fix will use some new functions merged into the php code and we try to provide this new php code as a patch so our fix will work with older php versions.

Thanks. Once the change is out I’ll be happy to test.

@marty

Hi, I was wondering when you think the fix will be completed.

Hi Marco,

For testing you can grab the php-kopano-smime package in the master directory:
E.g. for Ubuntu 16: https://download.kopano.io/supported/smime:/master/Ubuntu_16.04/amd64/php-kopano-smime_0.1-0%2B3.1_amd64.deb

And checkout branch “KSP-128-fix-ocsp-ca” in project SMIME: https://stash.kopano.io/projects/KWA/repos/smime/browse

Thanks :)

Hi,

Sadly I do not have access to that directory…

Is the build also available in the community overnight builds?

Thanks.

great thanks, I’ll have a look.

@marty

Question: I have downloaded the latest build from the community location and installed it as below.

root@mrc-ubz64:~# dpkg -l |grep -i smime
ii kopano-webapp-plugin-smime 2.2.0.150-0+81.1 all Kopano WebApp S/MIME plugin

When I upload the Comodo certificate, it asks me for a passcode (which I do not believe I have set) then says it cannot be decrypted.

What do I do?

Thanks for your help.

Hi Marco,

The certificate is probably installed in your browser. Check advanced settings and the certificate manager.
Make a backup with a password and upload the pkcs12 file again.

Hi,

I have started a new fresh browser, deleted all the history of everything, disabled everything and then went under S/MIME and tried uploading the certificate.

The certificate I try to upload is what I received from Comodo from the following web page:

https://www.comodo.com/home/email-security/free-email-certificate.php

You then receive an e-mail and you can download from their site the .cer file which I believe is the certificate.

But

S/MIME does not like it…

Am I doing something wrong (I am pretty sure I am).

Hi Marco,

That’s the wrong format.
Comodo installs the correct certificate in your browser, after clicking the link you’ve received via email.

After that you should make a backup of this certificate.

mmm… I am confused. When I click on the install certificate in the Comodo email it doesn’t install anything in the browser, in any case I’ll try…

Hello @mcostan,

if you are using firefox this should be easy:

click on settings -> advanced -> certificates
select the one which is related to comodo (should be installed after clicking the link in mail)
and click export… this should be a .crt file.
use that :)

Coffee_is_life

CentOS 7.4.1708
Mariadb-5.5.56-2
KC 8.5.1.0-8.1
Webapp 3.4.5.1202-47.1 (external Server - TCP-Socket)
Z-Push 2.3.9+0-90.1
PHP-MAPI: 8.5.1.0-8.1
DeskApp 1.5.0
DeskApp Devel 1.5.0
Outlook 2016(64bit) with KOE 1.6.244
Outlook 2010 - MAPI Zarafa Client 7.2.6

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.