Webmeetings never initializes

I have webmeetings-0.29.5_1-Debian_8.0 installed, and all the other Kopano functionality appears to work correctly, however the webmeetings icon always remains grey instead of turning green.
If i access the webmeetings url directly (https://mysite/webmeetings/) it says “Initializing” in the title bar but never appears to complete.
Comparing side by side with the Kopano demo site (https://demo.kopano.com/webmeetings/) i see a POST request to webapp_auth_userinfo.php and then the demo site makes a request to /webmeetings/ws but my install doesn’t even attempt to make this request (no error, nothing)…
I can’t seem to find any way to get verbose logging from the webmeeting server, and am completely stumped as to what’s going on. Does anyone have any suggestions?


Not sure whether you are using the Kopano official turn server, but if not, you may want to follow this thread.

This is how I got it to work.


to me this sounds a bit like not all of the configured “secrets” match. In the back of the webmeetings admin manual you can find an overview of these.

@mcostan the turn server only comes into play once an actual user to user connection needs to be established.

I’ve tried setting all the secrets to the same value, is there any way to get any verbose logging to see where it might be failing?
According to firebug the with requests are getting a valid response just no websocket request is ever being made

Are you running this behind NGINX following the Kopano web meetings instructions?

If you run it behind apache then you need to enable other settings.


yes you are right apologies. Indeed within the internal network it works without the turn server.

Yes running behind nginx as per the installation manual

do you get anything in the log file


do you have the service kopano-webmeetings running?

i.e. is something like this running:

4 S kopano 672 1 0 80 0 - 76116 - 12:22 ? 00:00:13 /usr/sbin/kopano-webmeetings -c /etc/kopano/webmeetings.cfg -l /var/log/kopano/webmeetings.log

Yes the service is running, and the 8090 port (from memory) is responsive…
The logs show the service starting, but no thing after that… no errors and no request logs even when I manually make requests directly to it

The log just shows:

server 2017/06/23 09:41:07 Using '/webmeetings/' base base path.
server 2017/06/23 09:41:07.245351 Enabled modules: [contacts roomlocking screensharing youtube presentation]
server 2017/06/23 09:41:07.245910 Using the number of CPU's (4) as GOMAXPROCS
server 2017/06/23 09:41:07.245918 Max open files are 1024
server 2017/06/23 09:41:07.246950 Enabled users handler 'sharedsecret'
server 2017/06/23 09:41:07 Starting HTTP server on

@bert64 have you solved the problem? because I’m running into the same thing

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.