Upgrade to MariaDB

Is it supported to upgrade from mysql to mariadb without problems?


@klausf that also depends on the version of mariadb.

As long as you are running a mariadb version that is equal or older to any of the officially supported distributions you should be good.

@klausf are you referring to the Debian 9 upgrade? I’d like to know if you experienced any problems.


Hello Felix,

thanks for this information. As yep_DD is asking, my question is regarding the upcoming Debian 9 in which by default mariadb instead of mysql will be the default. So I prefer to update to mariadb in Debian 8 and later, when Debian 9 will become stable do a dist-upgrade.


@klausf I personally never tried it on Debian 8, but as long as you take mariadb-server package from the jessie repository you should be good to go.

@klausf I just restored my server backup to a virtual machine and performed the upgrade to Debian9 and php7

These were the steps:

And what can I say… at least in the virtual machine everything is running just fine

edit: now I need to test everything is running just as it is supposed to before doing the same on the live system

@yep_DD many thanks for testing and your feedback!

Just to continue a bit, -in case you’re also running opendkim- these were the config changes that were updated and the selections I made:

  • spamassassin: local.cf -> N
  • iptables before.rules -> N
  • 50unattetended-upgrades -> Y
  • logind.conf -> N
  • sysctl.conf -> Y
  • apache2.conf -> N
  • default-ssl.conf -> N
  • samba -> Y
  • moduli -> Y
  • sshd_config -> N
  • jail.conf -> Y
  • security2.conf -> Y
  • /default/opendkim -> Y (!)
  • opendkim.conf -> Y (!)
  • apache.conf -> Y (!)

The (!) means changes were needed. Opendkim is now running chrooted so change to the sockets were made. The one thing that was a bit of a headache is that you need to re-compile the systemd init script by running “/lib/opendkim/opendkim.service.generate”, otherwise all change related to the socket settings in /etc/default/opendkim and /etc/opendkim.conf were ignored.

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.