• Hello,
    I just installed this service and I was able to login to an account that I created but when I tried to send an email, nothing happens.
    It stay on the Outbox folder. Doesn’t provide any error message or anything. How can I troubleshoot this?

    Thanks.

  • Kopano

    Hi @fanpero
    first of all you should check kopano-spooler for errors.

    greets
    Mathias


  • @mkuemmerle said in Emails stay on Outbox:

    check kopano-spooler

    Here is the status of that:

    Nov 05 12:06:31 kopano kopano-spooler[2002]: Starting kopano-spooler version 8.7.0 (pid 2002 uid 117)
    Nov 05 12:06:31 kopano kopano-spooler[2004]: Starting kopano-spooler version 8.7.0 (pid 2004 uid 117)
    Nov 05 12:06:31 kopano kopano-spooler[2006]: Starting kopano-spooler version 8.7.0 (pid 2006 uid 117)
    Nov 05 12:06:31 kopano kopano-spooler[2005]: Starting kopano-spooler version 8.7.0 (pid 2005 uid 117)
    Nov 05 12:06:31 kopano kopano-spooler[2006]: Connect to SMTP: Error while connecting socket.. E-Mail will be tried again later.
    Nov 05 12:06:31 kopano kopano-spooler[2006]: Unable to connect to SMTP server, retrying mail for user test later
    Nov 05 12:06:31 kopano kopano-spooler[2004]: Connect to SMTP: Error while connecting socket.. E-Mail will be tried again later.
    Nov 05 12:06:31 kopano kopano-spooler[2005]: Connect to SMTP: Error while connecting socket.. E-Mail will be tried again later.
    Nov 05 12:06:31 kopano kopano-spooler[2005]: Unable to connect to SMTP server, retrying mail for user andres later
    Nov 05 12:06:31 kopano kopano-spooler[2004]: Unable to connect to SMTP server, retrying mail for user fabio later
    

    I haven’t done any modification to the default “nano /etc/kopano/spooler.cfg” file

    ##############################################################
    # SPOOLER SETTINGS
    
    # Outgoing mailserver name or IP address
    smtp_server = localhost
    
    # Port number for outgoing mailserver
    smtp_port = 25
    
    # Server Unix socket location
    server_socket = default:
    
    # drop privileges and run the process as this user
    run_as_user = kopano
    
    # drop privileges and run the process as this group
    run_as_group = kopano
    
    # create a pid file for stopping the service via the init.d scripts
    #pid_file = /var/run/kopano/spooler.pid
    
    # run server in this path (when not using the -F switch)
    #running_path = /var/lib/kopano/empty
    
    # create memory coredumps upon crash [no, systemdefault, yes]
    #coredump_enabled = systemdefault
    
    # for temporary files
    #tmp_path = /tmp
    

    What do I need to make it work?

    Thanks.


  • I changed the Socket location line on “nano /etc/kopano/spooler.cfg”
    and now I’m getting a different error:

    Nov 05 14:38:11 kopano kopano-spooler[473]: <?xml version="1.0" encoding="UTF-8"?>
    Nov 05 14:38:11 kopano kopano-spooler[473]: <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:SOAP-ENC="http://schemas.xmlsoap
    Nov 05 14:38:11 kopano kopano-spooler[473]: gsoap connect: ()
    Nov 05 14:38:11 kopano kopano-spooler[473]: HrLogon server "/var/run/kopano/server.sock" user "SYSTEM": network error
    Nov 05 14:38:11 kopano kopano-spooler[473]: Unable to open admin session: network error (80040115)
    Nov 05 14:38:14 kopano kopano-spooler[473]: <?xml version="1.0" encoding="UTF-8"?>
    Nov 05 14:38:14 kopano kopano-spooler[473]: <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:SOAP-ENC="http://schemas.xmlsoap
    Nov 05 14:38:14 kopano kopano-spooler[473]: gsoap connect: ()
    Nov 05 14:38:14 kopano kopano-spooler[473]: HrLogon server "/var/run/kopano/server.sock" user "SYSTEM": network error
    Nov 05 14:38:14 kopano kopano-spooler[473]: Unable to open admin session: network error (80040115)
    

    This is the config file now"

    ##############################################################
    # SPOOLER SETTINGS
    
    # Outgoing mailserver name or IP address
    smtp_server = 45.62.203.208
    
    # Port number for outgoing mailserver
    smtp_port = 25
    
    # Server Unix socket location
    #server_socket = default:
    server_socket = /var/run/kopano/server.sock
    
    # drop privileges and run the process as this user
    run_as_user = kopano
    
    # drop privileges and run the process as this group
    run_as_group = kopano
    
    # create a pid file for stopping the service via the init.d scripts
    pid_file = /var/run/kopano/spooler.pid
    
    # run server in this path (when not using the -F switch)
    #running_path = /var/lib/kopano/empty
    
    # create memory coredumps upon crash [no, systemdefault, yes]
    #coredump_enabled = systemdefault
    
    # for temporary files
    #tmp_path = /tmp
    
    

  • @fanpero said in Emails stay on Outbox:

    /var/run/kopano/server.sock"

    Hi,
    who is the owner of /var/run/kopano/server.sock" ?
    Did you kill or stop the service?
    Is the service running in ps -aux|grep kopano?


  • @AnotherAndy said in Emails stay on Outbox:

    ps -aux|grep kopano

    Hi,
    Kopano is the ower of the file:

    root@kopano:~# ls -la /var/run/kopano/server.sock
    srw-rw-rw- 1 kopano kopano 0 Nov  5 14:34 /var/run/kopano/server.sock
    

    This is what I see when I run “ps -aux|grep kopano”

    root@kopano:/var/log# ps -aux|grep kopano
    avahi      470  0.0  0.0   8288  3292 ?        Ss   14:34   0:00 avahi-daemon: running [kopano.local]
    kopano     472  0.0  0.1 146408 15812 ?        Ss   14:34   0:00 /usr/sbin/kopano-ical -F
    kopano     473  0.0  0.3  85732 24912 ?        Ss   14:34   0:01 /usr/sbin/kopano-spooler -F
    kopano     478  0.0  0.2  84524 20800 ?        Ss   14:34   0:00 /usr/sbin/kopano-gateway -F
    kopano     481  0.0  0.2 281912 18160 ?        Ssl  14:34   0:00 /usr/sbin/kopano-monitor -F
    kopano     503  0.0  0.6 203132 53852 ?        Ssl  14:34   0:04 /usr/bin/python3 /usr/sbin/kopano-spamd -F
    kopano     504  0.0  0.7 292700 58444 ?        Ssl  14:34   0:02 /usr/bin/python3 /usr/sbin/kopano-search -F
    konnect    547  0.0  0.2 717300 19996 ?        Ssl  14:34   0:01 /usr/libexec/kopano/konnectd serve --identifier-client-path=/usr/share/kopano-konnect/identifier-webapp --identifier-registration-conf= --iss=https://kopano.newtws.com --log-timestamp=false --insecure --identifier-scopes-conf=/etc/kopano/konnectd-identifier-scopes.yaml --signing-private-key=/etc/kopano/konnectd-signing-private-key.pem --validation-keys-path=/etc/kopano/konnectkeys --encryption-secret=/etc/kopano/konnectd-encryption-secret.key kc
    kopano     976  0.1  0.2 1261348 20488 ?       Sl   14:34   0:06 /usr/sbin/kopano-server -c /etc/kopano/server.cfg
    kopano    1029  0.0  0.1  85284  9448 ?        S    14:34   0:00 /usr/sbin/kopano-dagent -d -c /etc/kopano/dagent.cfg
    kopano    1058  0.0  0.4 218924 37420 ?        Sl   14:34   0:00 /usr/bin/python3 /usr/sbin/kopano-search -F
    kopano    1059  0.0  0.3 218968 31084 ?        S    14:34   0:00 /usr/bin/python3 /usr/sbin/kopano-search -F
    root      2452  0.0  0.0   6208   888 pts/0    R+   15:45   0:00 grep kopano
    

    Thanks.


  • all right - so all kopano services are up and running.
    which smtp service do you use? looks like he can’t be reached.

  • Kopano

    @fanpero said in Emails stay on Outbox:

    smtp_server = 45.62.203.208

    you should really use a local mta here. connections from kopano-spooler to the mta are unathenticated.

    @fanpero said in Emails stay on Outbox:

    Starting kopano-spooler version 8.7.0

    these seem to be the packages that are included in Debian 10. These are already quite old and there are some known issues with them. I would recommend to request a trial subscription from Kopano sales and rather test with the our supported packages instead.