• We have detected that Outlook 2019 uses a different autodiscover, Z-Push reports this error:

    23/09/2020 07:57:34 [20964] [FATAL] [#unknown] FatalException: Request for a responseschema that is not supported (only mobilesync is supported): http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a - code: 0 - file: /usr/share/z-push/autodiscover/autodiscover.php:177
    23/09/2020 07:57:34 [20964] [FATAL] [#unknown] Exception: (FatalException) - Request for a responseschema that is not supported (only mobilesync is supported): http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a
    23/09/2020 07:57:34 [20964] [ERROR] [#unknown] Unable to complete autodiscover because of ZPushException. Error: Request for a responseschema that is not supported (only mobilesync is supported): http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a
    23/09/2020 08:11:14 [22193] [FATAL] [#unknown] Exception: (AuthenticationRequiredException) - Unauthorized
    23/09/2020 08:11:14 [22193] [ERROR] [#unknown] Unable to complete autodiscover incorrect request: 'Unauthorized'
    23/09/2020 08:15:59 [26876] [FATAL] [#unknown] Exception: (AuthenticationRequiredException) - Unauthorized
    
    

    The autodiscover of Outlook 2016 worked with Z-Push until recently. Since a few days we observe that the autodiscover of Outlook 2016 writes the same errors in the autodiscover.log as Outlook 2019. Is there any information that Microsoft has changed the autodiscover of Outlook 2016 in the last days with a patch?

    Environment: Z-Push 2.5.2, Debian 9, Kopano 8.7.14

    How can I make the autodiscover of Outlook 2016 and 2019 compatible with Z-Push?

    Any help is welcome.
    Walter

  • Kopano

    Hi @WalterHof,

    @WalterHof said in Outlook 2016 and Outlook 2019 error:

    The autodiscover of Outlook 2016 worked with Z-Push until recently. Since a few days we observe that the autodiscover of Outlook 2016 writes the same errors in the autodiscover.log as Outlook 2019. Is there any information that Microsoft has changed the autodiscover of Outlook 2016 in the last days with a patch?

    There was an Outlook update in September, but Microsoft didn’t detail what has changed: https://support.microsoft.com/en-us/help/4484511/september-1-2020-update-for-outlook-2016-kb4484511.

    How can I make the autodiscover of Outlook 2016 and 2019 compatible with Z-Push?

    First some information on autodiscover and what is implemented in Z-Push. First of all Z-Push only implements POX (plain old xml) autodiscover because it’s what the mobile devices use.

    In the autodiscover request there’s AcceptableResponseSchema tag. For ActiveSync accounts its value is “http://schemas.microsoft.com/exchange/autodiscover/mobilesync/responseschema/2006”. For an exchange account its value is “https://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a”.

    Z-Push only processes the request and returns a valid response if the client requests mobilesync schema.

    Z-Push doesn’t return a valid response for outlook schema because it’s not an exchange server (see https://docs.microsoft.com/en-us/exchange/client-developer/web-service-reference/pox-autodiscover-response-for-exchange how such a response looks like).

    So, if the client (a mobile device or Outlook) doesn’t request mobilesync as AcceptableResponseSchema, Z-Push autodiscover won’t work and the user has to configure the account manually.

    Manfred