kopano-server - An error occurred: no access (0xffffff9f)



  • Hi all,

    I upgraded community edition from 8.7.81.164 to 10.0.5.5 and now kopano-server doesn’t come up any more.

    journalctl -u kopano-server
    
    Mai 26 20:30:01 myhost systemd[1]: Started Kopano Groupware Core Storage Server.
    Mai 26 20:30:02 myhost kopano-server[2057]: An error occurred: no access (0xffffff9f). Please check logfile file:/var/log/kopano/server.log for details.
    Mai 26 20:30:02 myhost systemd[1]: kopano-server.service: Main process exited, code=exited, status=255/n/a
    Mai 26 20:30:02 myhost systemd[1]: kopano-server.service: Unit entered failed state.
    Mai 26 20:30:02 myhost systemd[1]: kopano-server.service: Failed with result 'exit-code'.
    

    unfortunately the log file doesn’t reveal any helpful information:

    2020-05-26T20:30:02.079689: [=======] Starting kopano-server version 10.0.5 (pid 2057 uid 0)
    2020-05-26T20:30:02.081772: [=======] Server shutdown complete.
    

    what can cause this trouble? I am using my old server.cfg but I also tried to use the original raw server.cfg from /usr/share/doc/kopano/example-config and the error is the same.

    when raising server.cfg log level to 6 (=debug) I also don’t get any revealing information:

    Tue May 26 19:30:01 2020: [=======] Starting kopano-server version 8.7.81 (pid 17083 uid 0)
    Tue May 26 19:30:01 2020: [=======] Starting kopano-server version 8.7.81 (pid 17083 uid 999)
    Tue May 26 19:43:39 2020: [warning] Shutting down
    Tue May 26 19:43:45 2020: [=======] Server shutdown complete.
    2020-05-26T20:23:03.360594: [=======] Starting kopano-server version 10.0.5 (pid 1237 uid 0)
    2020-05-26T20:23:03.362831: [=======] Server shutdown complete.
    2020-05-26T20:23:44.252261: [=======] Starting kopano-server version 10.0.5 (pid 1359 uid 0)
    2020-05-26T20:23:44.254349: [=======] Server shutdown complete.
    2020-05-26T20:24:46.736281: [=======] Starting kopano-server version 10.0.5 (pid 1446 uid 0)
    2020-05-26T20:24:46.738409: [=======] Server shutdown complete.
    2020-05-26T20:25:02.032093: [=======] Starting kopano-server version 10.0.5 (pid 1473 uid 0)
    2020-05-26T20:25:02.034109: [=======] Server shutdown complete.
    2020-05-26T20:25:43.328452: [=======] Starting kopano-server version 10.0.5 (pid 1567 uid 0)
    2020-05-26T20:25:43.330518: [=======] Server shutdown complete.
    2020-05-26T20:26:52.956348: [=======] Starting kopano-server version 10.0.5 (pid 1705 uid 0)
    2020-05-26T20:26:52.958827: [=======] Server shutdown complete.
    2020-05-26T20:27:23.260187: [=======] Starting kopano-server version 10.0.5 (pid 1789 uid 0)
    2020-05-26T20:27:23.262138: [=======] Server shutdown complete.
    2020-05-26T20:29:18.780928: [=======] Starting kopano-server version 10.0.5 (pid 1917 uid 0)
    2020-05-26T20:29:18.782954: [=======] Server shutdown complete.
    2020-05-26T20:29:51.952209: [=======] Starting kopano-server version 10.0.5 (pid 2029 uid 0)
    2020-05-26T20:29:51.954170: [=======] Server shutdown complete.
    2020-05-26T20:30:02.079689: [=======] Starting kopano-server version 10.0.5 (pid 2057 uid 0)
    2020-05-26T20:30:02.081772: [=======] Server shutdown complete.
    2020-05-26T20:35:02.132404: [=======] Starting kopano-server version 10.0.5 (pid 2259 uid 0)
    2020-05-26T20:35:02.134418: [=======] Server shutdown complete.
    2020-05-26T20:39:43.800331: [=======] Starting kopano-server version 10.0.5 (pid 2752 uid 0)
    2020-05-26T20:39:43.802440: [=======] Server shutdown complete.
    2020-05-26T20:40:01.172264: [=======] Starting kopano-server version 10.0.5 (pid 2784 uid 0)
    2020-05-26T20:40:01.174274: [=======] Server shutdown complete.
    2020-05-26T20:40:28.220693: [info   ] Audit logging not enabled.
    2020-05-26T20:40:28.220789: [=======] Starting kopano-server version 10.0.5 (pid 2864 uid 0)
    2020-05-26T20:40:28.220842: [info   ] Using epoll events
    2020-05-26T20:40:28.221866: [info   ] Listening on 0.0.0.0:237 (fd 5)
    2020-05-26T20:40:28.222770: [=======] Server shutdown complete.
    

    I just notice many retries of starting the server process (changing pids). Any clues? how to debug and solve?



  • well … I found THIS thread here in the forum. It points out to disabled IPv6 on the running server host.

    Yes, I have IPv6 disabled on my GNU/Linux Debian machine and testwise I enabled it and rebooted. Now Kopano-server starts. Conclusion: this Kopano version does run only when IPv6 is enabled. It will fail functioning when ipv6 is disabled. Is this a wanted and intensional behaviour of Kopano? Without the intesion to start an off-topic flamewar about IPv6 on/off on a Linux machine …

    … How can someone use Kopano 10.0.5* with IPv6 disabled ? any help appreciated.


  • Kopano

    @micro what exactly have you set as server_listen_tls?



  • Good morning Felix. No matter, because as explained before, this error occurs even when I use the empty default server.cfg from Kopano example-config. But to answer your question, my custom server.cfg is using

    server_listen_tls = *:237


  • Kopano

    my suggestion would be to replace * with something that only includes (a single) IPv4 address in your server.cfg.



  • Hi Felix,

    just tried your suggestion and it seems to work! I re-disabled IPv6 on my host and rebooted and ensured IPv6 was not present. Then I modified my server.cfg and replaced the line:

    #server_listen_tls = *:237
    server_listen_tls = 0.0.0.0:237

    Cheers
    µicro



  • Hello again,

    unfortunately I have to revoke the success message I posted ago. The issue still exists unless IPv6 is disabled on the host. Here are the details:

    After replacing the server_listen_tls directive in server.cfg as explained earlier, kopano-server fires up but there are services that are not working. Example kopano-gateway, kopano-spooler, kopano-dagent, just to name those for the beginning. I didn’t dive further into those single services, I just reverted the IPv6 settings and everything works fine.

    Background info how I disable/enable IPv6 on my GNU/Linux Debian system:

    in /etc/default/grub I am using this line:

    #GRUB_CMDLINE_LINUX="ipv6.disable=1"
    

    in this example IPv6 is enabled because the line is commented. Please note, after modifying /etc/default/grub it needs to run update-grub and then one can reboot to let the the new change take effect.

    Simply said: whenever I enable IPv6 it works fine, whenever I disable IPv6 Kopano functionality breaks.


  • Kopano

    Hi @micro,

    what exactly did not work with gateway, spooler and dagent? At least for gateway it uses a tcp connection to talk with the server, the other two by default use a unix socket (where I would not expect a difference between ipv6 active/deactivated).


Log in to reply