Install Kopano on Fedora 25

Hi all,

Do someone know how to install Kopano in Fedora 25. A lot of dependencies are out of date. I get errors like this “nothing provides libicudata.so.50()(64bit) needed by kopano-server-8.4.0~465-112.1.x86_64”.

Please help.

with best regards
hk

Really no one has an idea?

Hello @hkaiser ,

the fedora packages are not actively tested by us so it could be that the packages have wrong dependencies. I would rather recommend to try an installation based on CentOS or RHEL (if you’re married to rpm packages). Otherwise Debian is a solid choice as well.

After Fedora, I tried an install on Centos 7, but it is also inpossible, because it is impossible to resolve all dependencies. Centos ist a tested version of Kopano? Thanks in advance.

with best regards
HK

@hkaiser said in Install Kopano on Fedora 25:

Centos ist a tested version of Kopano?

It certainly is no favorite but is tested regularly. In fact just a few days ago I deployed a centos 7 machine with a master build to reproduce a report.

Hi Felix,

Maybe you have an tutorial which works? I took the zip-file from the kopano download page for Redhat 7, but the are so much dependencies to resolve. Only using yum localinstall or rpm seems to become a problem. Especially the order of installing the packages. Thanks in advance.

with best regards
HK

Hi Felix,

Yes i have tried this totorial, with it, I always get the dependencies problems. For example kopano-client needs libmapi, but libmapi needs kopano-client. So maybe there is a mor exact tutorial? thanks in advance.

with best regards
HK

Hi HK,

Maybe you can create a local repo so yum can fix your dependencies problems for you
Just unpack the tar.gz and use

createrepo /path/to/kopano/packages

Then create a repo list (e.g. /etc/yum.repos.d/kopano.repo)

[Kopano-core]
name=Kopano core
type=rpm-md
baseurl=file:///path/to/kopano/packages
gpgcheck=0
gpgkey=0
enabled=1

Then use yum to install the packages

yum  update
yum install kopano-server-packages 

Regards,

Robin

@robing +1 this would have been my next recommendation as well (apart from using something debian based, where you could so the same tricks with local repositories).

Hi,

@robing, @fbartels

A lot of thanks to you both, now it works. If someone else make it like this, please be careful with activating epel. But the installation worked like a charme.

Thanks again,

with best regards
HK

HI All,

Please be also aware that installation on Fedora 25 do not work in the moment, only Centos 7 i have tried.

with best regards
HK