Installationerror python3-graphi.mfr / kopano-graphi-bin



  • Hi,
    I just tried to install the latest communitybuild of Kopano Meet @ Debian 9. I never had Kopano Meet installed on my kopano-server.

    dpkg: Fehler beim Bearbeiten des Archivs python3-grapi.mfr_10.2.0+0.200fd8f-0+27.1_amd64.deb (--install):
     Installation von python3-grapi.mfr würde python3-kopano-rest beschädigen, und
     Dekonfiguration ist nicht erlaubt (--auto-deconfigure könnte helfen)
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von kopano-grapi-bin:
     kopano-grapi-bin hängt ab von python3-grapi.mfr (= 10.2.0+0.200fd8f-0+27.1); aber:
      Paket python3-grapi.mfr ist nicht installiert.
    
    
    dpkg: Fehler beim Bearbeiten des Paketes kopano-grapi (--install):
     Abhängigkeitsprobleme - verbleibt unkonfiguriert
    kopano-meet (2.1.0-0+353.1) wird eingerichtet ...
    kopano-meet-packages (2.1.0-0+353.1) wird eingerichtet ...
    Fehler traten auf beim Bearbeiten von:
     python3-grapi.mfr_10.2.0+0.200fd8f-0+27.1_amd64.deb
     kopano-grapi-bin
     kopano-grapi
    
    

    First one means that python3-grapi.mfr would damage python3-kopano-rest.

    Second one tells me, that there were errors with:
    python3-grapi.mfr_10.2.0+0.200fd8f-0+27.1_amd64.deb
    kopano-grapi-bin
    kopano-grapi

    Some advise on how to solve it, will be welcome. ;-)



  • so… hm… is the python3-kopano-rest package still only used in dev-environment? After removing the package, the DEBs for Kopano meet install without problems.


  • Kopano

    Hi @mcdaniels,

    what other (Kopano) packages do you have installed? If you have the core:final packages installed, then you should also install Meet from the meet:final repository.



  • I have the same problem with community version



  • Hi Felix,

    damn, I think I mixed up the nightly of Kopano Meet with the core:final. (testing machine). But on the other handside, the packages installed well, after I removed python3-kopano-rest.

    Concerning meet:final -> is this package only showing up whether we have licensed it (user-licenses). I heard that 10 users will be free. (Edit: Just saw, this is a dockerconfiguration).


  • Kopano

    Hi @mcdaniels,

    @mcdaniels said in Installationerror python3-graphi.mfr / kopano-graphi-bin:

    Concerning meet:final

    no this is more about the versions of the rest api that is part of the Meet repository. Since the initial release of 8.7 there was quite a lot of work put into it so the currently master packages are not directly compatible.


Log in to reply