CentOS 7 / Fedora 29/30 missing packages in nightly builds



  • Hello,

    I’ve tried to setup a fresh Kopano 10.0.1 server on Fedora 30, and fallback tried CentOS 7.

    In both cases, I created a repo from the kopano-core tar file (ie: core-10.0.1.182.86317a7-RHEL_7_PHP_71-x86_64.tar.gz).
    In both cases, I cannot install kopano since RPMs kopano-search, kopano-backup and kopano-dagent-pyutils are missing from the tar file.

    I’ve looked at the tar files for PHP7.1, PHP7.0, PHP5.6 and EPEL7, as well as in the tar files for Fedora 29/30.

    Is there anything I missed here ?

    Best regards.


  • Kopano

    Hi @deajan,

    yes. For Kopano 10 we have switched to Python3 for all services and this is a dependency that is not fulfilled natively on CentOS 7, therefore these services are missing in the archive.

    My general recommendation would be to switch to a Debian based distribution.



  • Thank you @fbartels .

    I finally installed the RHEL7-EPEL7 package which contained kopano-search.

    Running into problems with missing dependencies for xapian, I actually tried to build xapian-bindings-python from source, using v1.2 (not python 3 compatible) and v1.3 and v1.4 which both make kopano-search run into various store.py errors.

    I tried to solve the issues in various ways, in the end I understood that Kopano Core 10 is not ready to use xapian 1.4.x yet AFAIK.

    I am more or less RHEL bound, so I’ll stay on Kopano 8.7.0 as for now.
    Can you confirm that kopano-search 10.0.2 doesn’t work with xapian v1.4 yet ?

    If it’s supposed to work, I’ll happily make bug reports about it.

    Thanks.


Log in to reply