[Fixed] KC 8.4.0~667_139: Error while accessing html-mail-items in webapp

Hello devs,
recent changes to kc/mapi.so are causing the following problem:

When trying to open a html-based mail-item in webapp, an error-dlg pops-up "Could not open message" and the preview pane shows a centered "failed" text. This seems to apply for any kind of html-message.

  • No useful hints in php-fpm errorlog.
  • Messages are correctly shown in IMAP-connected clients.
  • Rolling back to core-8.4.0~644_137 resolves the issue.

CentOS 6.9
PHP-FPM 5.6.30
Core 8.4.0~667
Webapp 3.4.0.676 or 3.4.0.670

++umgfoin.

Hi @umgfoin ,

I just tried to reproduce your report on WebApp 3.4.0.676-474.1 and Kopano Core 8.4.0-669, also running CentOS release 6.9 (Final) and was not able to do so.

Hi Felix,
… not so good. I guess, the problem resides in php-mapi:

If I upgrade the core-installation (including a restart of all kopano-daemons), everything behaves normally until php-fpm gets restarted - which effectively reloads mapi.so, thus activating the new php-mapi.

That means core 8.4.0.667 with PHP-MAPI as of 8.4.0.644 is OK.

Enabling debug-output in webapp does not bring any enlightenment.

++umgfoin.

@umgfoin so you also see the problem with 8.4.0-669?

@fbartels

you also see the problem with 8.4.0-669?

Yes - last unaffected build for me was 8.4.0~644_137

Hello,

i have the same isue:

Ubuntu 14_04
KopanoCore 8.4.0.669
Webapp 3.3.0.610-25.1 or Webapp 3.4.0.676

regards
Carsten

hello @ck0ne ,

are you running php-mapi via php-fpm as well?

Same Problem. Did not find anything in the logs.

Ubuntu 16.04
Core 8.4.0-728
WebApp 3.4.0.686-479.1
php-fpm (PHP 7.0)

Additionally: on nine mail (android) some mails show myself as sender, which is clearly not the case. Different issue but new and z-push uses php-mapi. Just for mentioning it. Deserves own issue if I see a pattern. But maybe it is a hint.

@MacusRieche said in [Bugreport] KC 8.4.0~667_139: Error while accessing html-mail-items in webapp:

Same Problem.

Are you using PHP or PHP-FPM?

@umgfoin php-fpm as it is current in Ubuntu 16.04

(I tried deinstall of php-fpm so system works with plain php. All functions normal but the above did still not work. So I do not think the usage of php-fpm matters in this case.)

@umgfoin I run PHP without PHP-FPM

Thanks for all your reports. I have now created https://jira.kopano.io/browse/KC-709 to officially investigate this error.