Issue when make Kopano plugin for Mattermost

  • Hi, All, i got below error while i am trying to make the Kapano for mattermost plugin. Could you kindly let me know what i am missing?

    make: *** No rule to make target ‘webapp/workspaces/kopanowebmeetings/build/kopanowebmeetings_bundle.js’, needed by ‘dist’. Stop.

    Thanks and Best Regards,

  • Kopano

    Hi @wuyewuye,

    this seems to work here for me. Did you run make webapp before attempting make dist?

  • Hi Felix,

    I have the same trouble currently now. Regarding to your documentation:

    mkdir -p ~/go/src/
    cd ~/go/src/
    git clone <THIS-PROJECT> mattermost-plugin-kopanowebmeetings
    cd mattermost-plugin-kopanowebmeetings
    make dist

    There is no information about “make webapp”.

    Cheers, Tobias

  • Hi @fbartels ,

    tried now with make webapp but got this error:

    make -C webapp/workspaces/kopanowebmeetings js
    make[1]: Entering directory '/usr/local/go/src/'
    getting depdencies with yarn ...
      let {
    SyntaxError: Unexpected token {
        at exports.runInThisContext (vm.js:53:16)
        at Module._compile (module.js:373:25)
        at Object.Module._extensions..js (module.js:416:10)
        at Module.load (module.js:343:32)
        at Function.Module._load (module.js:300:12)
        at Module.require (module.js:353:17)
        at require (internal/module.js:12:17)
        at Object.<anonymous> (/usr/share/yarn/bin/yarn.js:24:13)
        at Module._compile (module.js:409:26)
        at Object.Module._extensions..js (module.js:416:10)
    Makefile:45: recipe for target '.yarninstall' failed
    make[1]: *** [.yarninstall] Error 1
    make[1]: Leaving directory '/usr/local/go/src/'
    Makefile:50: recipe for target 'webapp' failed
    make: *** [webapp] Error 2

    Cheers, Tobias

  • Kopano

    @TGM said in Issue when make Kopano plugin for Mattermost:

    There is no information about “make webapp”.

    Oh, yes indeed this bit of information is not covered in the readme. make dist is only used to package up already built artifacts and kopanowebmeetings_bundle.js is generated by make webapp.

    But if you have not build the plugin at all, then the dist target will fail at other files. Generally speaking you need to call make all dist, afterwards you should have an archive that you can upload to Mattermost.

    I will see if I can spent some time on setting up github actions for the repo so that there will be a build in the release section of Github in the future again.

    Edit: i have rebuild the latest tag and added the archive to Github manually:

  • Hi @fbartels ,

    thanks for the compiled plugin. I installed it now to mattermost and configured it. But I still have some trouble:

    “Kopano Web Meetings Server secure internal URL” points in my configuration to: http://server-who-is-running-kwm:8778

    But in the mattermost logfile I can see an HTTP 404 error. And if I call this URL directly in my browser, I get this error too. I think this error is related to a missing part in kopano-kwmserverd. Because Port 8778 is running for kwmserverd.

    But I do not know, what exactly is missing. Do you have any hints for me?

    Cheers, Tobias

  • @fbartels
    Too bad this plugin still does not work. I previously tried with a version that I compiled myself but just now uploaded your new release.
    Error is still the same old white screen once the plugin is activated. Chrome’s console is then spammed with this:

    The plugin’s config points to:
    Kopano Web Meetings Server URL: https://<URL-I-access-meet-webapp-from>
    Kopano Web Meetings Server secure internal URL: (kwmserverd is running on the same server)
    STUN server URI: default google
    TURN server URI: local TURN server that works with meet
    TURN user: <blank>
    TURN shared secret: <secret that works with meet / kwmserverd>

    Any help on how to configure this thing correctly is highly appreciated. I am running mattermost on and meet/kwm on

    Kind regards.

  • @TGM
    I assume you are not running kwmserverd and mattermost on the same server? You might want to try using an IP in that case and also open up port 8778 on the firewall.
    One other thing I have come across was a case in the past where my webserver (nginx) behaved funnily when there was a wildcard DNS entry for the domain I was using. Any request without a valid servername that then hit the server would be served a random server block (subdomain) which usually resulted in a 404.

  • Kopano

    @irreleph4nt said in Issue when make Kopano plugin for Mattermost:

    Too bad this plugin still does not work

    yeah, it was just a rebuild of an old tag. The initial white page is a known issue, but development of this plugin has no priority from our side (focus for us has moved to the standalone Meet).

    That calls do not work is probably because of the CORS errors on your side. Your webserver prevents you from cross domain requests (as it should). you either need an exception or proxy kwmserver from the same domain.

    As said in we are working on some projects to integrate Meet with other applications, but Mattermost has so far not been requested in these projects.

    @TGM said in Issue when make Kopano plugin for Mattermost:

    I installed it now to mattermost and configured it. But I still have some trouble

    In I have posted an example configuration with kwmserver and mattermost running on the same host.

  • Hi @irreleph4nt ,

    exactly, I am not running kwmserverd on the same machine like mattermost. But connecting to the IP / subdomain is allowed through the firewall. It make no difference if I call the URL http://IP-OF-KWMSERVERD:8778 or http://HOSTNAME-OF-KWMSERVERD:8778. Or if I call the on the machine where is kwmserverd is running.

    So I think there is something missing in the webroot of kwmserverd. But I do not know what exactly.

    @irreleph4nt what is happening on your machine, if you open:



  • @fbartels
    Hi Felix and thank you for getting back to this issue. I’d love to, as a first step, get past the “initial white page” but so far have not managed to do so. Can you point me at steps I’d need to take here? On CORS: my setup has always been on subdomains, so I’ll shuffle things around on a test box, move services to the same domain and then comment back on here. :)


    404 page not found

    So that’s probably not the right way of checking your config because I can confirm meet works for me, which by extension means kwmserverd works as well.

  • @fbartels

    thanks for the link but this change nothing. On the mattermost host I send all traffic to to the kwmserverd machine port 8778 via

    ssh -L 8778:kopano:8778

    So now I am able to open a connection on the mattermost machine to via curl. But still getting the error 404 error.
    I think there must be an issue with the kwmserverd. Here is the config of kwmserverd. Maybe you have a tipp for me:

    cat /etc/kopano/kwmserverd.cfg |grep -v '#'
    listen =
    log_level = debug
    enable_guest_api = yes
    registration_conf = /etc/kopano/konnectd-identifier-registration.yaml
    turn_uris = turn:turn.domain:443?transport=udp turn:turn.domain:443?transport=tcp
    turn_server_shared_secret = /etc/kopano/turn.secret
    public_guest_access_regexp = ^group/public/.*

  • @irreleph4nt

    meet just alone works for me too. But not together with mattermost.

    @fbartels do you know, which URL exactly the plugin is trying to open at the kwmserverd machine?

    On my installation Meet Webapp is running at: https://kopano.domain/meet and the Kopano WebApp is running at https://kopano.domain/webapp
    All Kopano-Systems are located on one machine and the mattermost is located on a different one, called mattermost.domain

  • Kopano

    @TGM said in Issue when make Kopano plugin for Mattermost:

    @fbartels do you know, which URL exactly the plugin is trying to open at the kwmserverd machine?

    Kwmserver exposes an API. For an example URL routing configuration, take a look at - Mattermost plugin uses API v1 while Meet uses API v2.

    Generally it is perfectly normal to get a 404 if you access the web server route of kwmserver (since nothing is there).

Log in to reply