Problems installing Final version of Kopano on Debian 9



  • I try to install Kopano on a freshly installed Debian 9 server.

    Debian version: 9.11 (stretch)
    Kopano repository:

    apt-get install kopano-server-packages

    The following packages have unmet dependencies:
     kopano-server-packages : Depends: kopano-backup but it is not going to be installed
                              Depends: kopano-dagent but it is not going to be installed
                              Depends: kopano-dagent-pytils but it is not going to be installed
                              Depends: kopano-gateway but it is not going to be installed
                              Depends: kopano-ical but it is not going to be installed
                              Depends: kopano-python-utils but it is not going to be installed
                              Depends: kopano-search but it is not going to be installed
                              Depends: kopano-spooler but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    

    It seems to boil down to:

    Package libical3 is not available, but is referred to by another package.
    

    which is not available in Debian 9, only in Debian 10?



  • try : apt-get dist-upgrade --autoremove --purge
    this upgrades and removed old not used packages,

    … wait… i now see, it was a fresh install. (sorry)

    Aare you using debian packages or Kopano packages?..
    Seems i cant read… Kopano packages.

    just checked my debian stretch server, libical3 does not exist.


  • Kopano

    Hi @TuxTiger,

    thanks for the info. We already noticed the same error with the nightly build this morning. Through an updated dependency this wrong dependency of libical3 was introduced. The package repository has been updated with a fix.



  • Thanks all! It installs now! :thumbsup:



  • Hey,
    i’m encountering the same issue with the current nightly build core-8.7.85.51.9bff5f8-Debian_9.0-amd64.tar.gz.
    kopano-ical depends on libical3, which is not available for Debian 9.

    @fbartels : You mentioned that the repo was updated, but the timestamp of the nightlies is still “22.11.2019 03:13”. Is there any way to get an updated version?

    Thanks, Stephan


  • Kopano

    Hi @Gazzis,

    the updated repo was the one with the supported releases. The nightly releases will be updated on the next automated push.



  • Ah okay, thanks for clarifying that.
    Nightlies have been updated as well now, so that topic is fixed for me.


Log in to reply