kopano update centos 6 missing libkcpyplug0



  • Kopano-Spooler not longer work:

    Sun Nov 17 02:20:55 2019: [error ] [ 3139] Cannot load plugin manager “libkcpyplug.so.0”: libkcpyplug.so.0: cannot open shared object file: No such file or directory



  • yum install libkcpyplug0
    

    Has solved the problem. I think the dependencies are not deposited.



  • kcpyplug is optional since a while. We added “Recommends:” tags, which will propose new subpackages for installation. If you use the package manager in a non-standard fashion, or when the package manager is configured to ignore recommendations, or if your package manager is just too dumb/old to not even have a concept of recommendations, then you don’t get it in an automated fashion.



  • @jengelh, Sorry but that is not exactly true. The default installation of Kopano on Centos/EL7 and, presumably EL6/Centos, requires libkcpyplug0 but it does not get installed. If you do not install it, sending e-mails will fail. It was installed as default in 8.7.5 but is no longer in 8.7.7 or 8.7.9.

    There are a couple of preferences you can change (plugin_enabled = no in dagent.cfg and spooler.cfg) so libkcpyplug0 is not required, but these are preffed on by default.

    There is a bug raised to cover the issue, https://jira.kopano.io/browse/KC-1643, and the fix should be trivial



  • 8.7.8 spec:

    %package dagent
    Summary:        E-Mail Delivery Agent for the Kopano platform
    Group:          Productivity/Networking/Email/Servers
    Requires(pre):  kopano-common = %version
    Requires:       kopano-dagent-pytils >= 8.7.6.7
    Requires:       kopano-lang = %version
    %if 0%{?suse_version} || 0%{?fedora_version}
    # kcpyplug is dlopened / RedHat7 has no Recommends
    Recommends:     libkcpyplug0 = %version
    %endif
    

Log in to reply